'Unable to build proxy' in M2Web

We’re using M2Web to access Simatic touchpanels using VNC. Some of the devices are giving the ‘Unable to build proxy’ error. This error appears randomly on devices that have been working flawless before. It also dissapears after weeks of getting the error.

I’ve been searching the forum and for what I understand it has nothing to do with settings or the device itself and even the cause seems to never been cleared.

Can we investigate this? Our customers are using this function and rely on it.

Thanks in advance

Do you have the device set just for VNC in eCatcher? Does there seem to be any consistency for when you’re getting this error?

The LAN device is added with ‘visible in M2Web’ active using only VNC. See picture;

I haven’t been able to find any consistency. I thought it might have something to do with the routing, but today I reverted it back to default (NAT on LAN Plug 'n route) and rebooted the device.

One device was working ok a month ago but suddenly started showing the message.

When the device is showing that unable to build proxy error, is it responding to pings when you’re connected over eCatcher?

Just wanted to check if you had any update on this case?

Sorry, yes and no. No update as nothing changed but to answer your questions;

The device that is currently showing the ‘Unable to build proxy error’ only has problems using M2web.
When connected using eCatcher the device does connect to VNC (viewer) and responds to Ping. Also new software can be downloaded.
So the problem only is within M2Web.

I could create a username with access to this device for you to check it out?

Can you try connecting over the app eCatcher Mobile and see if that works?

Tried and works without any issues.

Can I try changing which server your Ewon is connected to and see if that makes a difference?

Sure! Just let me know what information you need and how to send it, without putting it on the www for anyone too see.

If you can send me the Serial number that should be all I’ll need

Great news; we have found the problem. Or actually Siobhan Chapman of HMS did…
My colleague contacted him parallel on my request for help, didn’t know that.

Appearantly we were using special characters (&, ö etc) in the device name. M2Web can’t handle that. So we changed the device names and now it works!

1 Like

Thanks for the update, glad to hear it’s working now!