Unable to connect to more than 2 Siemens PLCs with isotcp on Flexy205


#1

Hi I am unable to connect to more than 2 Siemens PLCs using ISOTCP.

I have configured a single S3&400 topic with no address so that the address can be explicitly specified for each tag, update rate is default 2000mS.
The first 2 systems (S7-1500) added to the Flexy communicate using this server/topic no problem but the 3rd PLC (S7-1200) shows no connection. I’ve tried a second topic/server for the S7-1200 with and without specific IP address but that doesnt work either.

I’ve also tried a 3rd S7-1500 using ISOTCP but this didn’t work either and would only work using a separate OPC-UA server topic.

Unfortunately I cannot get the S7-1200 to work using OPC-UA as the PLC tags are not visible and anyway my preference is for my PLCs to be connected using the same method & server type.

I’ve followed all the instruction on server setup but can’t get more than 2 PLCs to connect with ISOTCP.
Any help would be appreciated.
Thanks

Neil


#2

Hi Neil,

Are you able to read the S7-1200 if it’s the only PLC that’s being read?

Here’s a little note we had on connecting with S7-1200 and 1500s


#4

Hi it turns out another post here provided the answer… S7-1200 plcs require get/put instruction to be enabled in the plc configuration - server - security. Everything works fine now. Kudos to original poster with a similar problem who solved this obscure issue. Many thanks


#5

Hi Neil,

Thanks for the help on this post!

Best regards,
-Tim