Unable to ping EN2MB-R Modbus side


I have an EN2MB-R connected to Rockwell L310ER V30. I read the manual and use the AOP to set up the unit which seemed straightforward. I added a Modbus server with client specified IP address but I cannot ping the Modbus port. I have used the same network range as Ethernet I/P side, or a different network range to the Ethernet I/P side, same laptop, or a second laptop but none work. I have been careful to apply the changes, allow the unit to reboot and disable the antivirus/firewall but I cannot ping the Modbus side. I can ping the Ethernet side easily.

What would be the next step from here?


Why do you need to ping the Modbus TCP port? This is a Modbus TCP client that will poll or write to your Modbus TCP servers. Have you tried that yet?

Hi Kyle

I did try the free Modbus utility from Schneider which we have used previously on other systems. When this failed to connect I thought ping would be easiest to prove the port was available to help with my troubleshooting, but from your reply is it possible the Modbus port does not recognize a ping?


Hi @LeonMiguel,

No, sorry about that. You actually should be able to ping the Modbus TCP Client side. You cannot ping the Ethernet/IP side. I was just wondering if you had tried setting it up and polling with it yet.

Are you able to see the device in IPConfig?

Are you sure your network adapter is in the same subnet and your ping is going out the correct adapter (if you have multiple adapters in the same subnet sometimes the PC won’t know which one to use). You could use Wireshark to make sure.

There is another free Modbus TCP scanner that I’ve used with good results called ModRSsim2 if you want to try it.

Best Regards,

Hi Kyle

Thanks for quick reply. I have set it up in RS Logix 5000 and I can see the Ethernet IP side from RS Logix and access all the parameters. With the adaptor address I tried the same subnet as the Ethernet I/P, a different subnet, a different Ethernet port (onboard first, then USB/RJ45 adaptor) and then the same variations on a separate laptop so I have exhausted all the options I can think of.

I will try the IPConfig tool tomorrow and also the ModRSim2 tool to see if I can get any further.


You can set the the Eth/IP and Modbus TCP adapters to be on the same or different subnets. They are completely independent network devices.

It is strange that you can’t ping it, but most likely it’s a networking issue. You may want to try temporarily disabling all other network adapters except the one you’re using to ping the Anybus.

Hi Kyle

I reset the unit back to factory default, set the IP again with IPConfig and ran the add on instruction from Logix 5000 but still no change - I can still see Ethernet I/P side easily but nothing on the Modbus side. I did disable all the other adaptors as suggested and tried a second PC but I cannot ping or see the Modbus with any simulator tool. I am not sure what I can try next?


You are going to have to create a case at https://support.hms-networks.com so your local support team can investigate the issue and take the appropriate action.

Thanks Kyle, I will follow up with our local team.


You’re welcome.