Unable to reboot Flexy 20x, unable to access Basic IDE tab

hi all,

I’m dealing with two issues here:

  1. I’m trying to access the Basic IDE in a Flexy from one of my business units. When I click on the Basic IDE from the eWon’s webpage, it stays loading forever. If I try to go back to any other menu, it doesn’t leave the grayed out ‘loading’ animation. There is no script inside this eWon.
  2. Since I can’t access to the Basic IDE, I’d like to reboot and try again, but when I try to reboot it asks for the password, I write the default password which gave me access to it in the first place, but it keeps asking for the password over and over, eventually displaying a timeout error.

I’ve also tried updating the firmware (currently 13.0s) via eBuddy. I can see the eWon in the eBuddy, but when writing the password, it tells me the password is not accepted. Again, this eWon has no assigned password except the default from factory.

Any suggestions will be greatly appreciated!


Have you tried using another browser? This sounds like a problem with the browser, maybe also try clearing the cache.

This is odd, are you sure you are connected to the correct Ewon? Do you have local access to the Ewon? If so, you could try a Level 1 reset (clears password config and restores to default). Hold Reset button while device powers on and until the USR button is blinking red, about 30 seconds. Do not hold button longer or it will reset the whole device to factory default. Once releasing the Reset button, you need to power cycle the Ewon.

thanks Kyle,

the issue was that the adm user had a different password set by the engineer who configured it initially. After using the correct password, we were able to reboot and access all the tabs.

However, this brings me to another issue. I was able to log in to the eWon even when the password was different than the default one. Many features were disabled, but I think this is a bug in the security. Any comments on this?

What version of the firmware is on the device? On very old versions of the firmware, you could see certain information about the device without logging in.

You can download the latest firmware here.

FW is 13.0s0.

Is this Firmware going to compromise the data transfer in the script? We want to collect tags on the MQTT protocol.

Thanks Kyke,


So you did log in with another user? The Ewon can have multiple Users with varying rights, but you cannot access the device without logging in.


No. I would recommend updating to version 14.0 using eBuddy, then you can update to version 14.3 or 14.4.

thanks Kyle,

I wasn’t able to access it without logging int, but I was able to login with the default user and password, although as you mentioned, with many features disabled.

I think we are on our path to test the MQTT. Thanks for your support.


Keep in mind that you can change the password for the default user by going to Setup > Users > Configure

A post was split to a new topic: BASIC IDE doesn’t stop loading