Updating CANBridge NT420 Firmware


#1

I have a CANBridge NT420, when I hook it up via USB to a computer and scan for devices in the Configurator (V5.1.2.817) I see the device was found but it is at V3.00.10. In order to configure it the device needs to be at least V4 or V5, how do I update my device’s firmware?


#2

You will find the information you need here and make sure to read this document as well.


#4

This gets me from V4 to V5, I need to go from V3 to V4. Are you saying I need to use the IXXAT CME_PN SW Update CANopen Configuration Studio 2.1.6.3585 to get from V3 to V4?


#5

After more exploring, it looks like I might possibly be able to use the gateway configurator to update the firmware. When I click “target” then “update firmware”, I am able to choose a file. The file given in the link you showed me only updates from 4 to 5, I get the following error:

Firmware Update (CAN Gateway Configurator V5.1.2.817)

Warning: Do not remove the device while updating!!!
Firmware version does not match: ‘V5..’ is expected, ‘V3.00.10’ is detected.

Error: Invalid update file.

Error: Update failed.


#6

Hi Russ,

I’m sorry about that. I need to actually contact another office to get those files for you, so it won’t be until Monday. I am hoping to have them in the morning for you.

Kyle


#7

Hi Russ,

Sorry for the delay. I just received this response:

The necessary files for the CANbridge NT update are on our webpage

https://www.ixxat.com/support/file-and-documents-download/software-firmware-updates

Additionally you can download it in the attachment below

Firmware update instruction (V4 (or V3) up to V5):

Please update the firmware V4 (or V3) in two steps to V5:

1.0. Install the VCI V4.0.793.0 (or higher) from our webpage:

https://www.ixxat.com/support/file-and-documents-download/drivers/vci-v4-driver

1.1. Connect the CANbridge NT device to the computer via USB.

1.2. Flash the below attached HEX firmware using the VCI4floadGUI tool

c:\Program Files\HMS\IXXAT VCI 4.0\VCI4floadGUI.exe
(The HEX firmware converts the V4 (or V3) to the V5.0)

1.3. Restart (power off/on) the device.

2. Flash the below attached HFU firmware using the below attached CAN-Gateway Configurator V5
(Target | Update Firmware)

3. Configure the CANbridge NT using the CAN-Gateway Configurator V5.

Let me know whether or not this works for you.

Thank you,

Kyle


#8

Thanks. So I found and opened the Vci4 flashloader, when I open it it automatically scans and finds my device without a problem. I then click the >> button next to the Source bar and I navigate to the only hex files I’ve been able to find on the website, which is titled CANbridge-NT_UPDv4tov5.hex. I then hit the Flash button, and it starts to write/erase files. However, the progress bar gets about 10% done then immediately stops, rescans the device and reads out that the device has the same firmware as before. I suspect that it is terminating the flashing process after not recognizing the firmware currently on it. Is there a file for V3 to V4 out there? The second link you gave me is showing as a 404 for me, so if the .hex files are there I don’t have access to them.


#9

Try this link:

https://www.ixxat.com/support/file-and-documents-download/drivers

Here are the direct links:

VCI 3.5.4.4543

VCI 4.0.793.0


#10

So I installed the VCI version 3.5, but that version won’t recognize my device when I open the flashloader or any other program that came with the 3.5 driver. It just says that no device is in the system. I’ve tried uninstalling everything else and just running v3.5, no luck, and when I reinstalled v4.0 that version can find my device just fine.

I also still can’t find a .hex file associated with v3 in any of the links you have sent. I feel I can still get this to work if I get an update file for 3 to 4.


#11

Are you using Windows 7 or Windows 10?


#12

Windows 10


#13

So I’ve reinstalled the VCI v4 driver software and tried to reflash the 420 with the V4 to V5 .hex file I have. I then reinstalled the can-gateway configurator and ran a scan for all IXXAT device, and my device was found with firmware version 5 on it. I couldn’t read from the target, and pressing the connect button didn’t do anything to it (STS light in the GUI remained gray).

I selected Target and then reset to factory settings, nothing seemed to change. I then selected Traget, then Update firmware. I used the latest CANbridge-NT_FW_0_5_1_2_R778.hfu I got from the website, and it seemed to update successfully. Now I have connected to the device, but the STS light is flashing green, when I hover my mouse over it a message pops up saying it is in an error state. When I try to read from the device I get two error messages, one saying file is corrupted and the other saying file is not available. I’m still not able to configure the CAN ports’ CAN mode or Baud rate, which is my ultimate goal here.


#14

This may happen if VCI v3 is not completely uninstalled before installing v4. Some of the files may not have been replaced. Make sure to reboot after re-install.

Also, make sure to follow all of the steps here starting on page 13:


#16

I eventually found that I am able to write a file to my canbridge, and when I read that back it is no longer showing as corrupted. I don’t seem to have all the functionality that is offered on the program, but I have enough for my own purposes. You can call this one solved, thanks for your help!


#17

Great! Let me know if you have any other questions about it.

Kyle