USB-to-CAN compact VCI4 crashes Windows10

I cannot get the USB-to-CAN compact adapter to work on my new PC.
Windows boots but when I try to activate the adapter with canAnalyser3Mini or my own applications, the computer freezes and reboots without displaying blue screen.

I have updated the USB-to-CAN interface to firmware v1.06.
The adapter works on my portable surface pro Win10

HP Workstation Z2 i9
USB-to-CAN compact 1.01.0087.10100

Best regards,


Could you give us the specs on the new PC that you’re working with to see if we can try and replicate the issue?

Do you have VCI3 also installed? It can cause Windows 10 PCs with secure boot enabled to crash. I would recommend uninstalling all versions of VCI and doing a clean install.

Also, any 3rd party anti-virus or other security software installed?

I have not installed VCI3 on this machine since I’ve been through a very bad experience with that driver on my Surface Pro Win10 laptop after the Win10 2019 spring update… After reading that VCI4 should be more stable I wanted to give it a try. The CAN interface did actually work directly after installing the drivers but not after reboot. I have tried a second adapter and that one also worked the first time but not after reboot. By switching USB port after start I did get one of the Interfaces to work again temporarily but not after reboot. This is a completely new HP Workstation without bloathware and a few applications installed. The PC crashes very hard when activating the CAN interface with freeze and black screen (not blue). I don’t think I want to try this many more times since sometimes it starts in recovery mode after the crash.
Best regards,

Hi Anders,

I am escalating your case over to our IXXAT team in the EU, because it looks like they are local for you and will be best able to help with this issue. You should be getting an email from them some time today. Please let me know if you do not hear from anyone.



Hi All,

I have a similar (or same?) problem on my Dell Latitude 5591 running Windows 10.
SerNr: HW341490
Revision: 1.6

Driver installed, Status-LED of USB-toCAN compact 1.6 becomes green, but when I try to start Device in canAnalyser3 Mini, I get a bluescreen telling me:


Same device is working without any issues on my old laptop running Windows 8.1

Best Regards


Hi Stefan,

I’ve created a case for you with our IXXAT engineers in Germany. There are some known issues with certain newer PC hardware working with the older USB-to-CAN adapters. I would recommend trying it with a USB hub with external power to see if it makes a difference.

Someone will contact you soon about the issue. Thank you.


The support team in Europe sent me an earlier version of the VCI4 driver (VCI-4_0_598_0_ATTEST). This driver seems to have solved my problems. I have the USB-to-Can compact intarface directly connected to my computer. Thanks!

OK great. I’ll post a link to driver here in case anyone else needs it:

Same for me. VCI-4_0_598_0_ATTEST1 is working :slight_smile:


![Annotation 2020-07-14 121931|643x499](upload://

this is the message we got from device manager , if we install the driver exe file then the window 10 will crash , only can restore the window after that.

hi can email me the driver ?

You should be getting it in your email.

I have the same problem with the 4.0.925.0 driver. Please send me the working one.

Download here

3 posts were split to a new topic: Usb to can not connecting