Usb to can not connecting

I have the same problem and i can’t download it from the link.

Hello @mauro280,

This issue seems to be an old one and the latest driver should resolve the issue. Have you tried the latest VCI v4 release from the ixxat site? These drivers are signed and we no longer have signed and unsigned drivers.

Support Area for Ixxat CAN Interfaces

I tried but now i have no communication of the USB-to-CAN compact in the CanAnalyser3Mini and if I try to scan with the Vci4 Flashloader it generates the hardware information of device not supported. How can I solve it?

Thank you

Hello @mauro280,

Exactly what model of USB to CAN do you have? Can you share the serial number for me to look up if you are not sure?

Does the device show up in Device Manager? Or do you see any errors?

Deryck

V1.5

1.01.0087.10200

Does the device show up in Device Manager? Or do you see any errors?

I see it in the device manager and I see vci4 flashloader as in the attachment

I am trying to find out if the device show up correctly in Device manager and if there are issues there. The VCI4 Flash loader is for firmware, there could be unrelated issues for compatibility with that particular tool, such as no new firmware. The fact that it is seeing at least seems to indicate the device is working with the VCI drivers and it should show up in CANanalyser.

Does the device show up as a device in CANanalyser?

Deryck

Yes but there is a red x

This looks more like an issue with the software being able to interact with the CAN bus. Is the device connected to a CAN bus? Is there any other software running that could be interacting with the device? There is also a possibility that the CAN controller was damaged in some way.

It looks like you are located outside the Americas. I would recommend opening a case on mysupport.hms.se if the device is damaged.

I try it connected to a can bus and I try it also not connected…the usb-to-can is working correctly on the old win10 Pc but not in the new one

Hi @mauro280 ,

Checking with a colleague he says this could be an issue with the 1.5 firmware in windows 10. I We would recommend running the following update tool on a windows XP PC, XP was the last version supported by 1.5.

Bootmanager_v0.2.7.0_USB-to-CAN-compact-v1.6.zip (70.9 KB)

There is also a chance that the PC it is not working on is not providing enough power to run the CAN side of the device. An externally powered hub should correct this.

I solved using the usb port of the dock station.
It doesn’t work with the usb port of the side of the laptop.

Thank you so much!

thanks for following up! Have a great week.

I updated the firmware version to 1.6 as you said to me and the result is windows crash as you can see in the attachment

Hi @mauro280 ,

Do you have any older VCI drivers installed?

Can you provide more details on what version of windows you are using?

When does the crash occur? Was it just when you updated the device or when you connect it?

I use windows 10 pro build 19042 and I updated the device with a windows xp Pc…now when I connect the usb to can compact at the Pc and I open the can analyzer 3 mini the Pc crashes…I disinstalled the driver and the Pc recognize automatically the hardware and install the last version of the driver…

Hi @mauro280,
You should have seen an email saying you had a support case opened. on mysupport.hms.se I am checking with my colleagues on the Ixxat team

While we wait for a response I would like to check what version of VCI you have installed. From add remove programs search for add remove programs and see what vci drivers are installed.

Deryck

  1. "… I connect the USB-to-CAN compact V1.6 at the PC and
    I open the canAnalyser V3 mini the PC crashes … "

1.1. The bluescreen is a progress quasi,
because the CAN controller was detected with a red cross before and
now the CAN controller was successfully detected :slight_smile:
(In any case the update of the bootmanager made the next step).
The USB-to-CAN compact V1.3 (from 2003) is 18 years old.
The USB-to-CAN compact V1.6 is obsolete since 2014.
The USB-to-CAN compact runs according to the USB1.1 specification
with 12MBit/Sec, that is not always backward supported on modern PC
with USB3.0 (5Gbit/Sec) and USB2.0 (480Mbit/Sec).

1.2. Could you please let me know the exactly type of the used PC?
(motherboard type and the type of the USB controller)

1.3. Can you reproduce the problem on another type of PC?

  1. Please connect the USB-to-CAN compact via an external USB Hub
    with an external power supply and let me know if the problem still occurs.

  2. Please deaktivate the “Selective Suspension” and “Activate Fast Start”:
    1 - Control Panel > Power Options > Change Settings Scheme > Change Advanced Power Settings > USB Settings > deactivate Selective Suspension
    or
    1 - Control Panel > Power Options > Change Plan Settings > Change Advanced Power Settings > USB Settings > USB Selective Suspension > disabled
    2 - Control Panel > Power Options > Choose What Power Buttons Do > Activate Settings Currentlly Unavailable > scroll down to Shutdown Settings > disable Activate Fast Start.
    and let me know if the problem still occurs.