VCI4 installation?

I had been running VCI3.5.2.4072 on our machines here without issue. I tried to install the latest VCI4.0.925.0. It complains about not having .NET 2.0 and 3.5 even though I have .NET 4.7.2 installed. And after it is complete, without the .NET 2.0 and 3.5 features installed, it won’t recognize and USB to CAN V2 devices. I tried to uninstall and roll back to my original 3.5 installation, and now that won’t work. Have you come across this before and do you have any directions to get past this?

Is this on Windows 7 or Windows 10? 32 or 64 bit?

I would recommend uninstalling all versions of VCI you have installed, then installing the latest version of VCI V4 and the VCI2 on VCI4 Add-On:

VCI2onVCI4_2_31_123_0.exe (1.3 MB)

It is on 64-bit Win 10. I will give that a try. Thank you

Peter T. Szymanski, Ph.D. | Senior Software Engineer

Hi Kyle,

I did uninstall all versions of VCI and the J1939 API that we had from IXXAT. I ran the install for both the latest VCI and the VCI2 add on. When I plug in a USB2CAN V2 device, the device appears in Device Manager, but it is unable to identify drivers for it. Additionally, when I attempt to update the driver from the device manager dialog for the USB-to-CAN V2 device, it is unable to load a driver, even though I point it to the correct directory. Do you have any further thoughts?

Is it still giving the .NET errors?

Please use the following directions to update the firmware:

No, the .NET errors are not there anymore.

I did try to update the firmware previously. It cannot update the firmware because it cannot detect the device. I.E., the device has no driver so the VCI4floadGUI.exe won’t connect to the device.

Have you tried it on another PC?

Do you have another USB-to-CAN V2 that you can try on that PC?

I am able to use any of our USB-to-CAN V2 units on other PCs we have, yes. Those PCs have VCI3.5 drivers on them, not the VCI4.

On the PC on which the VCI4 drivers are installed, I have tried two different USB-to-CAN V2 units and neither is recognized. Both units work on the other PCs.

I have tried installing the VCI4 drivers on a Win 10 machine and a Win 7 machine, both of which had VCI3.5 on them. Neither installation worked correctly.

Can you open CanAnalyser and let me know if it detects the USB-to-CAN V2?

Can you try updating the USB-to-CAN firmware on one of the working machines and then try it on the computer with VCI V4 again?

CANalyser does not recognize it, either.

Can I use VC3floadGUI.exe to update the firmware? I don’t have VC4floadGUI.exe on any other machine


I did update using the VCI3 version of the firmware loader and the latest USB to CAN V2 firmware. It still did not recognize the device on the computer with VCI4 installed. I uninstalled the device and then plugged it in and it said it
could not find the driver when it automatically tried to install the drivers for the device.

I am escalating this case. Which version of the USB-to-CAN V2 do you have? Do you have the serial number?

We have version V1.1, although I reprogrammed it to V1.07.00

Sorry, I should have been more specific. I was asking about the model, Compact, Professional, etc. There should be a sticker on the side with the serial number as well.

The unit I am using for my testing is

S/N: 1.01.0281.11001


HW P/N: HW442717

  1. Could you please let me know if the USB-to-CAN V2 is connected directly or via an external USB extension cable? (if yes, please let me know if you can reproduce the problem even if the USB-to-CAN V2 is connected to the USB directy)

  2. Could you please connect the USB-to-CAN V2 via an external USB-Hub with an external power supply and let me know if you can still reproduce the problem?

  3. Please delete the USB-to-CAN V2 entry in the device manager,
    unplug the USB-to-CAN V2,
    plug-in the USB-to-CAN V2 again and let me know if the VCI V4 driver was successful assigned to the USB-to-CAN V2.

  4. Please let me know the used PC type (processor type and USB controller type).

  5. Please let me know if the actual BIOS and motherboard driver updates from the webpage of the motherboard manufacturer are installed.

  6. I tried to install the latest VCI4.0.925.0.
    It complains about not having .NET 2.0 and 3.5
    even though I have .NET 4.7.2 installed.
    And after it is complete, without the .NET 2.0 and 3.5 features installed,
    it won’t recognize and USB-to-CAN V2 devices.

    The .NET Framework 4 is not backward compatible with .NET Framework 2 and 3.5.
    Please install the .NET Framework 3.5 if your application use the VCI3.NET API and
    install the VCI3.NET API Addon from our webpage.

See below…