Very slow communication when upload Studio 5000 Project

flexy205
rockwell

#1

Hi there support team!

I was helping a costumer to configure the VPN connection with a CompactLogix PLC over eCatcher on PC. When we try to upload the project from the PLC and edit, the upload is running for over 45 minutes. All communication to talk2m server was tested with “Talk2M Connection Checker” tool.

Get online with the PLC is very fast, but exchange data over this VPN connection is very, very slow!

I made a “tracert” function in Command Prompt and saw that the delay of the information outside my LAN is over 250 ms for each hop (please see photo attached). I think something is wrong and I need to fix it as soon as possible!


#2

FYI, traceroute pings each hop individually, so those ping times are normal. For more info see https://support.microsoft.com/en-us/help/314868/how-to-use-tracert-to-troubleshoot-tcp-ip-problems-in-windows

Please provide a traceroute to device.vpn8.talk2m.com from the network that the Flexy is connected to.

Also, from that network, please go to www.dslreports.com/speedtest and select your connection type to start the test. When finished click “Copy and Share” and click “URL” and copy and paste that url in your reply, like this: http://www.dslreports.com/speedtest/51839957


#5

Hi Kyle,

I’ve checked the connection, and all that we talked about. But the communication still very slow, I can’t upload a project from the ControlLogix. Everything seems ok inside my IT platform and with the flexy, but the connection still not working.

Is there any other option for me to try?


#6

Do you have a mobile hot spot or some other internet connection that you can use for the sake of troubleshooting?


#7

We already tried it with 3 different internet connections, using cable, because we have only the Flexy205 with no expansion modules.


#8

@Chanlucas,

By different internet connections, are you saying you connected it to completely different networks (different external IP addresses, see whatismyipaddress.com) or to another cable or switch at the same location (same external network or IP address)?

If you only have an ethernet on the Flexy, you could either:

  1. Use a hotspot with a wifi to ethernet adapter like this
  2. A cellular modem like this.
    or
  1. Use a Flexy cellular card like this.

You could also take the Flexy (and PLC) to a different location entirely and try it.

This is the next logical step that needs to be taken in order to eliminate the network as the issue. Other than doing this, if you could provide packet captures and firewall logs we could take a look at those, but I’d prefer to try another network first.

Kyle


#9

I am assuming you have already updated the firmware on the Flexy to 13.3 and are using the latest version of eCatcher.


#10

Yes for both.

I sincerely don’t have any idea of what’s going on.


#11

My previous question was the important one, we need to test from another network entirely to eliminate the network as the source of the problem: