VPN Tunnel Error

recently when i try to connect to one of the Routers connected with our eCatcher software i always get following error:

“VPN Tunnel Fehler: Error: When using --ip-win32 netsh, if you have more than one TAP-Windows adapter, you must also specify --dev-node”

I already tried to delete the TAP-Windows adapter and after that i ran addtap.bat and renametap.vbs and it still wont me the favor.

I run Win7 Prof. SP1 64 bit. and eCatcher 6.3.7 build 27686

Best Regards,

Robin Sperling

Please try navigating to this directory on your local PC:

C:\Program Files (x86)\eCatcher-Talk2M\Talk2mVpnService\conf

and replace Talk2MClient.ovpn with this file:

Talk2MClient.ovpn (734 Bytes)

You may need admin rights to do so.


Did that, now he says “Tap Windows Adapter ´talk2m-ecatcher´ not Found”
tried renametap.vbs and it showed the same error.
after that tried addtap.bat and renametab.vbs
still same error

OK, it sounds like you are going to have to manually rename the TAP adapter.

Go to Control Panel\Network and Internet\Network Connections, right click the TAP-Windows Adapter, and rename it “Talk2m-eCatcher”

Sorry for the late anwser, I tried to rename the TAP-Windows Adapter but i get a error notification that there is already a TAP-Adapter called Talk2m-eCatcher
Just now i reinstalled eCatcher but to no avail.

Hello Robin,

If you are seeing this error it means the device was not removed from your PC correctly. you can check in the device manager on your pc and see if it shows up there and remove it. If it is not there you would need to manually remove it from the registry.

A work around for this would be to have ecatcher use a different name then the default.

To do this you will need to open notepad as an administrator then open and edit the Talk2MClient.ovpn file in C:\Program Files (x86)\eCatcher-Talk2M\Talk2mVpnService\conf

Changing Talk2m-eCatcher in the 9th line to a new name. for example: –dev-node “Talk2m” then change the name of the adapter to match. Keep in mind if you reinstall eCatcher you will need to update this again since these are not the default settings.



I changed the name in the .ovpn and in the Networkconnection. After that i restarted eCatcher, and now i am back to the first Error.
What would the Steps be which i have to follow to find the regarding data in the registry?

This post may help with the tap adapter issue

1 Like