WAN / LAN setup - Flexy205

Dear HMS support team,

Could you please help me with this question/issue? I’ve to connect a PLC to our cloud tomorrow with a Flex 205 and the customer just informed me about a case I didn’t face before.

Objective: poll tags from an Allen-Bradley PLC with an eWON Flexy 205 and send it to AWS via a MQTT basic script (internet via ethernet)

Issue: the machine network is connected to the internet (the machine has a static IP of 192.168.2.xx ; for internet access DHCP is used)

Question: how do I set this up with the eWON? (can I connect the WAN port via ethernet and access the PLC and the internet simultaneously; do I connect 2 separate ethernet cables 1 from the WAN and 1 LAN port to the same switch or is that setup not possible with the eWON?*)

  • If not, what would be a solution?


Alexander Ubl


Cel: +49 170 921 0800



You will need to seperate the WAN side and the LAN side.


WAN: 192.168.2.x
LAN 10.10.1.x

If your PC is on the local internet, you can access the ewon device and PLC’s normally through eBuddy. If you are remotely connecting the device, you will need to connect through eCatcher/VPN.

You can enable WAN connectivity through networking settings as highlighted below:

Ultimately, you will need to remove the PLC from the network, and set to a LAN network with the eWon Device.

Hi Kevin,

Thanks for you quick answer. However, I’m not sure if this answers my question/ if I understand the answer correctly.

The customer mentioned that the machine network (PLC network) is connected to the internet (this probably can’t be changed).

I’m used to connecting the eWON via WAN port to the “internet network” and via LAN port to the “PLC network”. How do I connect the eWON in the case mentioned above to the PLC and internet? àphysically (how to plug in ethernet cables) & from a settings perspective.




Unfortunately, This will not work. If the DHCP for the internet appears on the on the LAN side, you will have an IP conflict that will render the ewon device usless.

You can provide internet to the LAN side as stated in the document above, and remove the PLC to the LAN side of the ewon device. The PLC will have internet connection, and there will be no IP conflicts.

Hi Kevin,

Why would there be an IP conflict if both ports are connected to the same network? The customer’s DHCP server should assign an IP to the WAN port, and we can reserve an IP on the DHCP server and configure the eWON’s LAN side to use that IP, no ?

This would mean we use 2 ethernet cables from the customers switch (1 to the LAN port, 1 to the WAN port).

Please let me know if this would be possible. Thanks!



The LAN and WAN need to be on sperate networks. They must contain different subnet ranges.

If you connect the DHCP server to both the WAN and the LAN side, the device will not function.

Thanks for explaining this again.



Hello Kevin,

The customer also has Wi-Fi. Would it work to connect the eWON LAN with the PLC network and use a Wi-Fi module for WAN? Which conditions apply for the Wi-Fi network in regards to being related with the ethernet WAN? (which is the same as the ethernet LAN)



The WAN requires the same conditions regardless of the conneciton method.

Which is not under the same dhcp Server?

Holen Sie sich
Outlook für iOS

My apologies, it should work fine. Try your connection and let me know how it goes.

No problem. Just for my understanding, could you please confirm both cases again:

Topic closed due to inactivity.


What is the issue that you are currently experiencing?

Hi Kevin,

I am experiencing the same problem.

I have connected two separate ethernet cables to Flexy 205 - one to the LAN and another to the WAN. Both ethernet cables are connected to the same router at other ends. I also have a WiFi card installed in the Flexy 205 and connected to the same network.

LAN port IP is (Static)
WAN port IP is (DHCP)
WiFi IP is (DHCP)

I am not able to establish communication on WAN port. If I chnage LAN IP to, the WAN is working okay. The moment I change LAN to, the WAN stops working. The WiFi card on the Flexy 205 keep working on the same network and IP range irrespective of LAN IP.

Is there any workaround to make WAN and LAN work on the same IP range?


There is no work around for the LAN/WAN network to operate in the same IP range. Both networks must be on a different subnet.

Thanks Kevin.

I have now installed an additional router between WAN and Network and changed IP range for the WAN.

Glad to hear