Web Server Password Protect

I am attempting to follow the instructions in the manual to password protect a directory on the built-in web server. I created the web_accs.cfg file as directed and after uploading it I am prompted for a user name and password. However, no matter what combination of user name and password I enter, it does not accept it. In addition, it does not display my custom prompt. Is there anything I could be doing wrong?

Here is an example of what my web_accs.cfg looks like with some test user/password combos:

Myuser:Mypassword
Auser:bpassword
admin:setup

[AuthName]
A password is required to unlock Settings.

Hi Tim,

What anybus device are you using? This look like it should be correct. Maybe you are using a device or firmware that does not support this?

I am using Anybus CompactCom 40 Ethernet Modbus-TCP running firmware 1.12. Are there any known incompatibilities?

I ran into some similar error when I just tested it. It ended up being a formatting issue with the web_accs.cfg file. Internet explorer of all programs happened to give a better error then the one in chrome. Attached is the file I was able to get working web_accs.cfg (73 Bytes)

I tried your web_accs.cfg file but still was not able to get it to accept the combination Myuser/Mypassword in either Chrome or IE. I was able to get the AuthName text to display when using IE, but it’s still nowhere to be found in Chrome. I’m not as concerned about that as I am getting it to accept the login credentials.

Are you seeing any error like this when you use internet explorer.
image

Can you share your web_accs.cfg file for me to review and test?

For the time being I am using the exact web_accs.cfg file you provided with no modifications.

The highlighted box is where it shows the AuthName text, as such:
Login Dialog

I discovered that if I put the web_accs.cfg file in the root web directory, it allows me to log in correctly. However, if I place it in a subdirectory, it refuses to accept the user name and password. My objective is to have the root directory open to everyone, but have a subdirectory that is only accessible to authenticated users. Is that possible?

Hi @timf,

This should work in other directories by just placing the web_access.cfg in the folder. I ran some tests and was able to get it to work as expected with our EIP firmware but ran into issues with the modbus tcp version. I will need to report this to development.

I swapped out the Modbus module for an EtherNet/IP module running firmware 1.40, and it seems to act the same as the Modbus module. The file works in the root directory, but does not permit logging in when placed in any other directory. We do normally use EtherNet/IP for production, so getting it to work there would be the priority.

I updated the EtherNet/IP firmware to 1.50.02 and am still having the same issue logging in to any directory containing web_accs.cfg other than the root directory.

Hi @timf,

Deryck is out this week. The bug has been reported to development so that they can work on a fix.

Best Regards,

Kyle