X-Gateway Ethercat to Modbus TCP with Kuka robot and Beckhoff EK1100


We recently acquired an Anybus X-Gateway (Ethercat to Modbus TCP https://www.anybus.com/products/gateway-index/anybus-xgateway/detail/anybus-x-gateway-ethercat-slave---modbus-tcp-server). I am trying to interface the Anybus with a Kuka robot that we have on the Ethercat side. I downloaded the ESI file(s) for Ethercat from the webpage for this device and uploaded it to our tool that interfaces with our robot (Kuka WorkVisual 5.0), but am getting errors.

Do you have any guidance on specifically how to interface the Anybus with Kuka (specifically the Beckhoff EK1100 Ethercat Coupler)?

In terms of wiring, I have powered the Anybus and have wired an Ethernet cable from the output of the EK1100 to the input port of the Anybus on the Ethercat side. I have not modified the ESI file retrieved from your product page.


What are the errors that you are getting after installing the ESI file for the Anybus? Can you share any screen shots or documenation from Kuka?

I think the best resource for interfacing with the Beckhoff would be here but you will also want to read Network Guide - EtherCAT Slave document and other resources found on the Product Page.

This is the pinout for EtherCAT on RJ45:



Thanks for the pointers. I’m still running into some issues – help would be appreciated.

Kuka configuration:

We have the Anybus powered, and an Ethernet connection from an EK1100 output located in the robot controller to the EtherCAT input on the Anybus.

I tried importing the ESI file provided on the website and adding it to the Kuka configuration as we installed it. This does not error, but upon uploading this configuration we get an error which says: “Ethercat device: Anybus X-gateway – Slave cannot be started” and “Error on reading/writing X-44” (an EtherCAT comm error).

The ESI version from the website appears to be 29.3. Version in the ESI is #x00010009 .

Anybus configuration:

When I plug an Ethernet from the Modbus TCP side to the computer, I am able to go to the Anybus webpage and have configured the IP address.

The EtherCAT slave version from the Anybus device page is software version 2.04, bootloader version 2.00. The Application version for the gateway is 3.29.

I tried following the documentation that you pointed to (the TwinCAT system manager guide), but was unable to configure the network card in the computer (network card is Realtek PCIe FE Family Controller) and got the error “Failed to install TwinCAT RT-Ethernet Intermediate Driver” on the PC I was using. This is in step 4.1.

My understanding is that this software is used to configure the I/O and generate an ESI XML file, which we should be able to upload to our robot configuration, I believe.


Alex Kearns

This error, what are you getting it from, the Kuka WorkVisual software?

Does the software allow you to download the process data object (PDO) from the gateway?

Try this file:

ABXS_ECT_V_3_22_Fixed_PDO_256bytes_for_OMRON_1.xml (116.9 KB)

Topic closed due to inactivity.