X-Gateway Terminal session


#1

@anonbqaejlhw
Hi Suzali,

Try using the USB connection COM port for the terminal session. It should work, but you need to power cycle the gateway after you open the connection.

Kyle


#3

Kyle,

I am able to communicate with Anybus module using the USB cable. However, I could not communicate with Anybus using the serial port for the detection of ASi valves.

Now, I have 2 unit of AB7820, 2 unit of USB to serial communication, 2 serial cables and a brand new computer just for the purpose of solving this communication issues.

Please give me a call to go thru the procedure on how to get this communication going over the telephone or using TeamViewer. I have try too many times without any success. Otherwise, I do need to get your tech support to come over my place in Greenwood to resolve this issues. We have many system using this AB7820 module in the next few months. If this fails, I have to find another option.

Do we have to reload the firmware to reset this device?

Best Regards


#5

Suzali,

You need to use a null modem cable (or adapter) to connect to the Master Config Connector:

image

PLease try that and let me know-

Kyle


#6

Emulation:ASCII
Baud rate:57600bps
Data bits:8
Stop bits:1
Parity:None
Flow control:None

POWER CYCLE DEVICE ONCE CONNECTED

If this still isn’t working tomorrow, please give us a call at 312-893-5636


#7

Hi Kyle,

Try it. Still does not work.

Best Regards


#9

Can you try another PC?


#10

Hi Kyle,

I try on 2 different computer. It does not want to communicate via serial port.

Best Regards


#11

Please use the USB port not the serial DB9 port to create the Terminal session:

  • Download and install the Anybus Transport Provider.
  • Connect your PC to the USB port on front of the gateway.
  • Open Windows Device Manager and find the COM port number that shows the X-Gateway
  • In Hyperterminal, select that COM port and start session
  • Power cycle the X-Gateway

#12

Hi Suzali,

I apologize but havent’ been able to determine yet why the Master Config serial port is not working in the case. If you do want me to take a look at it, we are located at:

HMS Networks (ATTN: Kyle)
77 Sundial Ave.
Suite 302W
Manchester, NH 03103

I will let you know if I find any new info in the mean time. Thank you for your patience on this issue.

Kyle


#13

Good morning,

There is one other thing that a colleague of mine has suggested in this case. There should be an included cable which is a null modem cable. He says if it is not working, try swapping the ends that are connected to the gateway and PC.

Kyle


#14

Hi Kyle,

I have shipped the AB7820 unit to you, arrival Monday by 10 am via FedEx.

Tracking #: 776519032696

Please contact me if you don’t receive it by noon today.


#15

Thank you, I received the device and immediately tested it. I was able to get a terminal session working with the AS-I master on Port X1.1. So I was wondering what the issue was that you were having so I tested using the cable in the box. It did not work so I swapped the ends and it did work! I think there must have been an issue with some of the cables that went out with these devices because it was just as a colleague described - the included cable only worked one way. Please test this with the other device and let me know if it fixes the issue. If not, try another cable. Remember that it needs to be a null modem cable. If it still is not working than I suspect there is an issue with the USB to serial adapter.

Please let me know what you find and I will send back your device with a working cable.

Kyle


#16

Hi Kyle,

I got to that communication page by reversing the cable as you mentioned.

However I am still not able to detect any ASi that already been configured. The AUP is still RED solid. Please give me a call at 804 316 7670 to discuss.

Best Regards


#17

Hi Kyle,

This is the slave device I try to communicate with. Please keep the AB7820 for until I ask for it.

Best Regards

PD ThinkTop-reg-AS-Interface-31-node-or-62-node.pdf (739 KB)


#18

The manual says there are two interface options. Have you tried both?

image


#19

Hi,

It all depends on the ASi master. Does the master has 2.1 or 3.0. The valve will accept/communicate w it.

Suzali


#20

The X-Gateway:

  • Complies with the AS-Interface 3.0 specification
  • Controls up to 62 AS-Interface slaves
  • Supports Combined Transaction Types 1, 2, 3, 4 and 51
  • Up to 248 digital inputs and 186 digital outputs
  • Up to 124 (16-bit) analog values
  • AS-Interface baudrate 167 kbit/s

What did you mean by:

?

Did you get the slave to show up in the Master Config?

Kyle


#21

Kyle,

What I mean is the slave device (Alfa Laval ASi Valve) will accept ASi Master that communicate with ASi 2.1 or 3.0 protocol. For V2.1 it will display a slave profile 7FFF and V3.0 it will display profile 7A77. It is not that we can select whether to use ASi V2.1 or V3.0.

I have configure all my ASi valve using the IFM ASi addressing tools but when when connected to the Anybus AB7820, it did not detect it. Light of UAP is solid RED.

Best Regards


#22

Hi Suzali,

I’m sure you have it hooked up as the documentation shows, but can you try switching the cables just in case the documentation is wrong?

I don’t see any reason for this not to be working. The devices are compatible.

Kyle


#23

Hi Kyle,

Finally I found the problem. The panel builder wired a GND wire to the AS- on the ASi Power supply. This inhibit the ASi communication. Now the Anybus AB7820 can detect all the slave valves that I already addressed using the ASi addressing device.

Please return the AB7820 unit to the following address:

Thank you for your support.

Best Regards