eWON fley 201 urs led flashing continuously

My eWON Flexy 201 User LED started flashing RED After I performed a firmware update. The unit was operating on firmware 12.1 but I updated to 13.2s0

Right now, the unit can’t be recognized on the ebuddy and the urs led continues to flash RED

I did double check my PC IP address to ensure it does not conflict with the previous IP Address assigned to the eWON device.

Any help or ideas on what could be done to resolve this issue?

Do i need to return the unit to your factory?


What steps did you take to preform the update from 12.1 to 13.2s0?

Below are the steps:

a. Connected the eWON device to the my PC via ethernet cable and power up the eWON device
b. Changed my PC IP address to be on same network with the eWON default IP Address (
My PC IP address was set to as10.0.0.55, Subnet
c. Open up ebuddy, selected the eWON device in ebuddy window and hit the Firmware Button, the SN automatically showed on the field, So i hit the next button

d. From the Drop down manu, they were 3 firmware listed.
So I selected 13.2 and hit the next button.

e. After the firmware update, I cycled power to the eWON device, boom the usr LED started flashing continuously.

Please what can I do to fix this issue ?
I have down level 1 and 2 reset but its still not working.
eWON device can’t be recognized on eBuddy window


There should have been an option for a 13.0* as one of the updates. This pivot upgrade is required first before you can do the 13.x upgrades. If you are not able to see the device in eBuddy you can try resetting the IP using the Set IP button and typing in the SN of the device.

If the device is still not showing you will have to preform a level 2 set on the device then you can restore a backup of the device.

I have tried both options as suggested but the urs LED is still flashing RED, the eWON device can’t be recognized on eBuddy.

Please how can I resolve this issue ? Can I send the device to you?

Please try the recovery process described in this post.