Ewon Rebooting from Watchdog in process (opcuacom)

Every three minutes the eWON reboots due to a watchdog in process (opcuacom)
Is there a fix to this?

Hi Ben,

Can you send us a backup.tar file from eBuddy with the support files included?


I just reformatted the device. I did grab this picture before then.

When I unplug the ethernet cable going to my HMI, it does not reboot.

I downgraded the firmware to 13.3 and this seamed to stop the constant reboots.
Let me know if you need any more information.

It might’ve been the re-flashing of the firmware that fixed it, but it’s hard to say what might have been causing the problem without being able to get a backup of the device before.

i have a similar error when i try to write the value of a string to my S7 plc, and in the plc the address of the tag is not present, if i disconnect the cable, the ewon stop rebooting…

There was a fix in firmware 14.2 for watchdog reboots. Have you tried updating to 14.2?

Yes, the problem remain… it is not a watchdog problem.

if you want to replicate:

define a string tag s7 and in the io address field write an address of a db that is not loaded in the plc
in the basic script ini section try to write a string in this tag; run the script;

the ewon reboot… and restart… and reboot

but… if you disconnect the cable between the ewon and the plc… ewon stop rebooting


Could provide a backup with the support files for us to look at?


unfortunately i can’t, but it’s very easy to reproduce te problem as described in my previous post

I’m not sure if this is a bug or expected behavior as you’re intentionally trying to write to an address that doesn’t exist, but I’ll look into it.

if i try to write a real, bool , int, i have no reboot; if i try to write a string, i have the reboot, for me it’s a bug

So I’m going to escalate this case so the developers can take a look at it.

@iw3bti1, you have an account with mysupport.hms.se and your case will go through the EU office, so you may get an email from them.

@BenKropidlowski, can you please provide a company email, or company name/address to open the case under?


2 posts were merged into an existing topic: Reboot reason: Watchdog in process (opcuacom)