31912 - esync-Internet communication failed, 25003 - IP-Read from server failed


I had both a flexy and a cosy im trying to put into the same system, I have set both of them up individually (so they arn’t on at the same time). I can connect both to the internet but after about 5 mins the errors below come up:

31912 - esync-Internet communication failed
25003 - IP-Read from server failed

It then wont connect to the internet. If i complete a factory reset, reput all the IP’s it connects then again after 5 mins the same 2 errors come up.

Thanks for response in advance


What is the network set up? Is it done by DHCP or Static IP?

It looks like the network could be cutting the connection to the Ewon units after the devices are online for about 5 minutes.

Can you attach a backup with support files of the unit? This can be done with ebuddy while connected to the device.


Thanks for your response,

I factory reset both units and uploaded the same config files and it worked,


I believe I have similar problem.
I have the EWON COSY131 connected in a static IP network, where all the traffic is allowed, as per the IT words, and although I have internet connection, the EWON cant talk with Talk2m network.

Correct, this is an IT issue. Please refer them to the information here:


There is more involved than just allowing ports. Make sure they actually read the document.

I sent the document but, just to clarify, here is the backup file I too from the router.


Looking at the backup confirms that this appears to be a network issue. Check if they are doing packet inspection on the network. If so, the Ewon will need to bypass this. If the firewall is doing Application Layer filtering, make sure OpenVPN is allowed.

Thanks I sent the info to the customer’s IT.

Can we have a meeting with some time frame?

This is the note sent from our customer’s IT.

In response to the notes from HMS Support, we have packet inspection and application filtering turned off for the Vendor connections.
Here are the screenshots of the firewall rule that applies to the Elink (Ewon) and specifically the intrusion and file policy turned off.

You would have to first create a support case at https://support.hms-networks.com.

Looking through the backup again, I noticed in the comcfg.txt settings (Setup > System > Storage > Edit COM cfg) I noticed that VPNCnxType is set to 0 (disabled). Can you please make sure this is set to 2 (VPN to Server).

Also, does it still fail the Talk2M Connection Checker test from that same network?

The settings are done to have both, the PLC and the HMI computer able to come to internet through the EWON.
The HMI Computer has one NIC in the same network as the equipment. It has also a second NIC (USB Antenna) the customer set up for us to do the EWON Setup.
The connection checker goes through the NIC2 (actual Internet) and not the NIC 1, unless I could redirect its path through NIC1. If so, how can be done?

I will try setting VPNCnxType to 2.

VPNCnxType to 2. It worked immediately. Thanks.

OK great! Let me know if you have any other questions.