Ab7072 communicating with Controllogix plc and with Em6400ng

I am having issue while communicating AB7072 Convertor with Em6400NG Schneider Multifunction meter. Anyone can help me to sort out this.

Hi @vel_murugan,

I should be able to help you out from the perspective of the Communicator. What issues are you having?


In field type I just selected Ethernet ip & modbus tcp-2 port.
Physical standard rs485 baud rate 9600, Parity none, data bit 8 and stop bit 1.start address 402700 data direction read, length 10

Same setting I just made in Mfm but still it is not communicating.


Do you see any data in the Log? Can you take a log and upload it here along with your configuration?

In the log we should at least see Rx data go out. Then either error response or no response from the slave. If you see error responses you should be able to correct accordingly. If there is not response then there could be an issue with your wiring.


Thanks for your reply.
Oh okay I will take log and will upload in the morning. Any sample configuration can you able to provide for this.

log.txt (4.8 KB)
Untitled.cfg (16.0 KB)
Kindly check it and reply.

Hello @vel_murugan,

Looking at the log and the configuration the communicator seems to be running correctly. It looks like the slave device is not responding to the transmitted requests. Double check your wiring and serial settings. Its a common error for the Rx and Tx line to be mixed up, you could try swapping them.

You could also be using the wrong node ID for the slave device so it is not responding to the device.


Thanks for your reply.
Anybus to modbus slave problem was fixed. I am able to communicate with slave now. But I am not able to communicate anybus with control logix PLC. If you are having control logix PLC backup kindly share here.


I recommend taking a look at our app notes explaining the Rockwell configuration. You can add it as a generic module or using the EDS file.

The eds file is available on the files and documents page for the device.


While I am trying to use EDS. I am not able to modify input size. And in online it’s showing input size error #0128

What version of the Allen Bradley software are you using?

V24 logix designer.

There is an issue with older versions of AB software where you cannot adjust the data sizes. You will need to use a generic ethernet module instead of the EDS file. Here are the assembly instances you will need.

Input assembly instance = 100
Output assembly instance = 150
configuration assembly instance = 1 (size = 0)

1 Like

Thanks for your reply.
I am reading 48 bytes that means 12 data dint data type and 0 output.
How can I meantion this in input output size. It show 32-bits. I can give 12 in input size and 1in output size?.

It sounds like the issue is that you do not have output data, which is not an option if you are not doing an input only connection (Allen Bradley software will not allow and output size of 0). If you put 1 in output and you do not have any output data defined you will get a data size mismatch.

Normally it is necessary to add data or triggers that do nothing in the output side of the communicator to adjust for this.

1 Like

Thanks for your reply.
I will try this.

I just tried. It’s working fine no problem in IO configuration. I am getting value in different format. I just tried byte reversal. It’s not working or their is no improvement. I am just tried bit swap in Anybus configuration after that also I am not getting correct value. I am using Em6400NG as modbus slave. It has all data in float format that is two register. Kindly look at my configuration,register detail and value I am getting in PLC. MFM.cfg (16.0 KB)

Hello @vel_murugan,

What values are you expecting to see and can you provide the actually bytes being read in by the communicator?

Did you try 2 byte swap? Also, since two registers are used for a float32 value registers could be off by one or combined incorrectly.

Thanks for your reply.
I got the correct value by using two byte swap.

1 Like

Great! Thanks for the update!