Accessing tags via eSync

I have set up a Flexy modem in a PLC application. I am able to access the Flexy remotely using eCatchter and am able to view the I/O data through the internal eWON page. It is unclear to me what to use for the server URL under the Data Management tab so that I can view data through eSync. Ultimately, I would like to set up reports in a sql based web application using this data.


Are you planning on using eSync as a standalone server application or in conjunction with the Data Mailbox?

Stand alone application


The data url to be used for the Data Management URL needs to be the IP addres on the eSync server that is reachable by the eWON. Are you using a public address on the server or are you going to be using a server within the WAN/LAN networks of the eWON?

It is a public IP address. eSync is currently installed on my personal laptop. I am just testing out the viability of this equipment for my company and eventually we would have a dedicated server. eSync has been installed and is listening on port 81. So should the server URL be ‘public IP’:81?


That is correct. The server url needs to be the public IP of the server you are going to have it interface with.
You additionally will need to create the device in eSync and add the device credentials from eSync into the eWON.

Have you taken a look at this reference document?

I have read through that document. I copied and pasted the eSyncID from eSync into the eWON Data Management ID. I have put ‘Public IP’:81 into server URL. I have set up no password (empty) into the server synchro in eSync and left the password blank on the eWON. After updating all changes, I run ‘DMsync’ in the Script Control command and I continue to get ‘httpc-http connect error’ in the diagnostic event log.


That error means that the EWON is unable to access the server at the IP address you have provided. Does the eWON have valid internet access? Are we certain the PC has the correct public IP?

I assumed that the eWON is working correctly because I can access it through eCatcher. Is that not necessarily the case? I am getting the public IP from “” and confirmed with a google widget.


Ah that answers things. The public IP address you are seeing on that site is the address that is assigned to your internet router. This cannot also be used on your PC. You will need a secondary public address specifically for your server or you will need to use a PC within the same network.

If you do not wish to use a public IP address, I would recommend using the Data Mailbox and the eSync Connector.

This is a great option that completely negates the need to have a public IP address or domain name. It users our Talk2M infrastructure to manage the data transfer between the two sites.

The eWON now says ‘esync-End of Data management export (0 min.)’ after a sync request. I believe that I have set up the eSyncDataMailboxConnector correctly by extracting to the eSync file, changing the config.ini file, running installEsyncDmConnector.bat and then running SyncData.bat. I still do not see any data in the View I/O tab or the Connections History tab of eSync.


Can you send me the login details to your eWON in a private message?


Thank you for providing the login details.

I have found your issue on the eWON end. You had actually selected to only export tags in group A however you didn’t actually have any tags in group A. So when the data was exporting it was actually exporting an empty log file.


After deselecting this I can now see data from your unit on the Data Mailbox.

Can you confirm if you see the data in eSync?

Aahh, I think I mistook group A as topic A. Thank you for catching that!

I am still not seeing any data in eSync though. If there is no data management ID on the eWON sending the data, how does eSync connect to any specific data points?


Do you have a developer id? Did you configure the DM connector as explained in the document prior to running the syncdata.bat?

The connector uses our API to grab the units in your account with data on the Data Mailbox and then inserts it into eSync.

1 Like

First off, I want to thank you for your extreme patience with me! It appears to work now!!

I do not have a developer ID. I reinstalled the DM connector. This time I copied the zip folder into the eSync folder before extracting and this appears to have worked. Previously, I extracted the zip folder from my download folder into the eSync folder. In doing this an eSyncDataMailboxConnector was never created, the files in the folder were simply extracted directly into the eSync folder itself. I assume this left the files in the incorrect file path.


Excellent news! As long as your config.ini is configured properly you should be good to go!

So I think there was a 2 part issue.

  1. The data being sent was for a tag group not in use.
  2. The connector wasn’t fully installed.

I am glad it is up and running! As always it is a pleasure to help out.