Anybus Gateway Not Connecting to MAPS program via USB

The Gateway device (Order Code INBACMBM1000000, MAC: CC3F1D03E1B4, Type: IS-IBV6-ETH-RS485-RS485/RS232) is not connecting to the MAPS program via USB. It is physically connected to my PC (Windows 10) using the included USB Mini device, I know the COM port it should connect to, and Button B is illuminated with an amber light. When I select the COM port to connect, the MAPS program tells me “No gateway found in COM[X]”. I’ve tried updating the firmware on an associates recommendation, but I get “Unable to connect with the device. Unknown error -2”. Is there something I’m missing in order to connect?

No, there is nothing special that needs to be done. Windows should automatically detect the baud rate. You could try changing the COM port number.

Have you tried connecting via Ethernet cable?

Tried ethernet but no luck, the device didn’t even activate any lights. Also tried every different COM port on my pc and still no connection. Do I need to apply some external power source to it?

Does the gateway need a power source?

Yes, of course!

9 to 36 VDC, Max.: 260 mA, 2.4 W
24 VAC +/-10% 50-60 Hz, Max.: 100 mA, 2.4 W

We recommend: 24 VDC with at least 100 mA

I would also recommend reading the manuals: Modbus TCP & RTU Master to BACnet IP & MS/TP Server Application (