Anybus x-gateway CANopen master / slave Ethernet IP config

connection assistance:
I currently have a CAN / J1939 bus system connected to an anybus x gateway CANopen - Ethernet/IP adapter. I am having issues uploading / downloading configurations to this module via the USB port the error only says module responded with error. any assistance would be great.

Hi Todd,

Can you please provide the article number or serial number for the device? Also, let me know if you know what version of the firmware it’s running.


Article -AB7306-B

Serial – A041CE4D

F/W – 3.03

Teleradio CANopen – (J1939) handheld remote control

I can connect / go online and the diagnostic tool says I have a valid configuration.

I can send whatever documentation you may need for discussion.

Plan to communicate from CANopen to Ethenet I/P Allen bradley


The USB port is only used for firmware upgrades. To configure the CAN network using Anybus Configuration Manager - CANopen, you need to use a USB-to-CAN adapter. Are you going to configure the AB7306 as a master?

CAUTION: This email originated from outside the organization.

kyle_HMS HMS Technical Support
January 27

Hi Todd,

Can you please provide the article number or serial number for the device? Also, let me know if you know what version of the firmware it’s running.


Any updates or ideas to help me along on this issue


I need an answer to my previous questions in order to help:

Do you have the USB-to-CAN adapter?

Are you configuring the AB7306 as the Master?

Sorry I missed the previous mail. Yes I wanted to use the AB7306 as the master (Allen Bradley rslogix interface) / the slave is a teleradio wireless remote control device that will simply let me know on the CAN network when buttons are
pressed. I do have the documentation ill send with this.

I also purchased from you the USB to CAN Ixxat module HMS 1.01.0281.12001 USB to CAN V2.

OK. Have you gone to the Product page here: and downloaded the Anybus Configuration Manager for CANOpen, reviewed the manuals and watched the video?

Yes I’ve looked at the documentation and have tried multiple things … not sure what I’m missing at this point. Seems almost like a CANopen hardware incompatibility issue but not sure. Maybe a little more direction would be great.

Please send your configuration from the Anybus Configuration Manager and the documentation for the teleradio device.

Can you be a little more specific about what you have tried? Did you add the EDS file for the teleradio to the config? Did you try scanning the network? What color are the frames around devices? Were you able to connect and download the configuration to the Anybus? If you haven’t yet, make sure to check out the manual for the software in the Help Menu.

It looks like it connects but I cannot download to the module it fails with the USB or Enet connection also I do not find any devices connected to the CANbus when I scan for devices although I do see some feedback on the diagnostics.

See attached pics.

TS-Protocol-0020-CANopen_Panther.doc (294 KB)

IM-PN-RX105-A02-EN.pdf (1.74 MB)

You cannot connect and download to the device though the USB or Ethernet adapter. You must use the USB-to-CAN device to connect you computer to the CAN bus.

Please watch the demonstration video:

Have you set the node address and baud rate using the switches on the Anybus? Does the baud rate match the configuration and the TeleRadio?

Have you tried activating the network using the included CANAnalyser mini software? What does it show?

Are you using terminating resistors? Can you send me a picture of your CAN bus?

Is the Ixxat USB to CAN V2 the correct device to connect to use to connect my computer to the CANbus?