Attempting to Pull Configuration off of Existing Anybus Communicator CAN

I am attempting to pull a current configuration off of an Anybus Communicator CAN - PROFINET IO unit. The contractor that initially configured this unit is no longer around. I am attempting to use the Anybus Configuration Manager - Communicator CAN program, with my computer plugged into the unit directly with a USB-A Male to USB-B Male chord (not the chord that came with the unit, which I do not have access to). My computer can see the Anybus unit on Com Port 3, and when I go to Online > Select Connection I can click on Anybus USB (UCOM) and click config, and under Module Serial I can see my device (A04DAE23). If I select that device and the Anybus USB, when I click connect the program starts thinking and never stops.

Windows will say it has stopped responding and I can then manually close the program. I have left it for 30 minutes at longest with no change. If I unplug the device, it no longer shows up in the com ports as expected, and no longer shows up as an option under the module serial. If I click connect without it being plugged in, it simply says there is no device. The device is currently installed in a control box with everything that is part of the subnetwork, namely an ethernet switch, a Siemens S-1200 PLC, and the controller for which the Anybus is communicating with the PLC. All of these functions are currently on, though the error is repeatable with both power supplied and removed. Please advise as to what may be happening here, as I am stumped. Thanks in advance!

Make sure that you download and install both “Anybus Configuration Manager - Communicator CAN” and “Anybus Transport Provider” from this page.

You may need to power cycle the Anybus as well.

Let me know if the problem persists.

Hi Kyle,
Looks like the problem still persists after cycling power and redownloading and installing both the configuration manager and the transport provider.

Can you try power cycling the Anybus either right before or right after clicking “Connect”?

Have you tried this with a different PC yet?

Tried both, the second PC doesn’t freeze completely, instead I get a Failed to Setup Connection message. The power cycling has the same effect with either doing it before or after.

Are you connecting the USB directly to the PC or through a dock or USB hub?

About how long is the cable?

Have you tried a different USB cable?

Are both of the PCs you tried on the same enterprise domain? (Do they have the same security settings, anti-virus, etc.)?

If we can’t get it to connect, we may have to factory reset the device, which will clear the configuration. Are you able to get a copy from the company who created it?

Also, have you tried assigning the Communicator a new COM port number in Device Manager?

What is the status of LEDs on the Communicator?

Can you share some screenshots?

Hi Kyle,
I am connecting directly to the PC, but my cable is very long and I’ve only tried that one. I don’t have another on hand but let me go get a much shorter one and see if that helps. The PCs don’t have the same security settings, though I will try disabling the anti-virus as well. I have tried getting a new COM port number. For LEDs, 1, 2, 5, and 6 are solid green, 3 is blinking green, and 4 is off. I do not have the ability to get the configuration from the company that created it, but I do have a few other control boxes in the same configuration as this one, so I will also attempt to pull off of a different Anybus with the same config. I’ve attached some screenshots of the behaviour here. I’ll send another reply once I’ve tried these fixes. Thanks!

This is very unusual, but I have seen some issues when using a very long cable or USB hub, so I’m hoping that getting a shorter cable will fix this! Also, a good idea to try another device if you have access to one.

Hi @GrahamPowers,

Any luck with a new cable?

Do you see this in the Device Manager?

Hey Kyle,
Sorry that took so long for me to get back to you, all of the places I went managed to be out of that specific cable somehow! I did finally find one and just connected it, it does appear that the length of my other cable was the problem, as I am now connecting just fine. Thanks for your help!

Great - thanks for the update! Let me know if you have any other questions.