BASIC IDE doesn't stop loading

Hello,

I am facing the same issue 1. where the IDE just keeps loading (even changing pages/logging out after navigating to the IDE page will cause the loading icon to persist on every page). I am able to log in using the default adm credentials, and I have checked the user settings - there is only 1 adm user with full permissions.

Checking the network console, i find this websocket error. I have run a wireshark trace on the PC but found no errors. The script running in the IDE is still running as I am still receiving MQTT data in my server.


Could anyone offer some advice?

Have you tried a different browser?

Tried clearing browser cache?

Do you have any browser extensions, like script blockers active?

hi Kyle,

Thanks for the quick response. Yes we have tried with different browsers on different machines, clearing browser cache etc. No extensions were installed. All ports, Connecting to the Flexys with LAN doesn’t have this problem, only when trying to connect remotely.

Do you have any Viewon pages running? If you have an error on a ViewOn page the error messages go to the IDE environment.

Do you have the latest firmware installed?

No Viewon pages running

Yes latest firmware is installed, i have several Flexy205s with different firmware versions, all having this problem, including the ones with the latest firmware

Are you able to narrow it down to:

a. A problem with your PC, or
b. A problem with your network?

You can do this by testing with another PC or the same PC on a different network.

Can you please test this on another PC and let me know if the problem persists.

Also, try connecting from a different network (i.e. a WiFi hotspot or a home network) to see if you still experience the problem.

You can also try logging in with M2Web to test.

I’ve tried with multiple different PCs, all have the same problem. I can only work within a private WAN, the Flexys are equipped with a private WAN sim and has no internet for M2Web or any other network.

This is the wireshark trace


where the .86 is the flexy and .238 is my server, seems like there is no network error.

So you are connected through the WAN interface, not the LAN interface?

Can you create a backup of the Ewon using eBuddy (please include Support Files) and share that so I can see the settings and logs on the device?

Yes connected through the WAN. Using LAN connection has no issues.

Please see attached
Backup (22).etar.gz (28.9 KB)

There appears to be some errors in your code. If you disable stop the BASIC script from the LAN, can you then access the section from the WAN?

all the Flexys are installed at site and gaining access might be a bit difficult. I am still receiving MQTT data in my server from the Flexys though, and nothing has changed in the past few months (and it was running fine), and suddenly this issue occurred about 3 weeks ago.

Is the websocket connection failure somehow related ?