Copying variables into another eWon

I have set up a second eWon Flexy205 and want to use the same variable list and basic program from the first in the second one. I have copied the basic program into the second one but dont know how to get the variables.

Hi Thomas,

Can you show me what the code is that you’re running into issues with? I’m wondering if you’re trying to call tags that may have not been created yet?


Not having problem with code. I am setting up a different Flexy205 to collect data from a different machine. It will basicall have all the same variables as the first and i dont want to re- create all the same variables in the 2nd one. I basicall want to export the variable list from one and import into second.

I’m responding again because I dont see my last response. My problem is not code related. Code working fine. I want to create the same list of variables in a second Flexy205 that i have in another one without having to re create all the same variables manually in the second one

Ok I see the issue now, you can do this by going to the Files Transfer section below and grab the var_lst.csv from the flexy that has the values you want:

After that, connect to the flexy you want to push the files onto and go into its FTP with something like filezilla or just through the file browser. Then you should just be able to paste that var_lst.csv file into the directory and it will add in the new tags

I got the first part. Let me save to my computer but I cannot get that file copied into the directory I tried dragging it off my desktop into the file location, didn’t work. Nothing give me the option to paste.

Here’s how you can do it with filezilla:

First just enter your ip address/usr/password/21 and hit connect


Next navigate to the folder that has the var_lst.csv or var_lst.txt. right click on it and hit upload and then you should be good


When you say enter “your” IP address, what up address are you referring to? My computer, eWon vpn, or eWon lan?

The LAN IP address of the flexy/cosy

ok Tim, im good on everything except the email. I have the same code in both ewons. One send emails the other one doesn’t. The sendmail has worked many, many times on the one. Never on the other.

Hey Thomas can you go to this section in the flexy that’s not working and check the smtp server?

If that part looks right can you check here and see what the status of the sendmails are?

That was it. The and password weren’t in there.That’s weird because I don’t remember setting that up in the first one. Anyway now I have to go shut off my annoying test email that keeps going off every 10 sec. Lol. Thanks Tim

1 Like

Haha welcome,

Every once in a while when I help somebody set one of these up I forget to take my email out of the test and get a ton of emails too

Hey Tim,
One more thing to get resolved. I’m going to need to log a LOT of data for a few days. I had put an SD card in my first one, Got it formatted correctly and can see in the system area that it shows the memory there for the SD card. What I don’t know is if/how to actually use that memory. But mainly I need to log the data on the one I just installed so I’m either going to get another SD card or move the one over because I’ll have limited time on my visit to the plant tommorrow. Can you help me with that? Let me know. Thanks


Hi Tom,

I think the code that Angela wrote in the post below should be useful for this:

Hey Tim,
I have an issue with the eCatcher application. I have 2 computers that I use it on and they both worked the same at one time. My newer computer, that I use the most, all of a sudden started to display the screen the nothing but the status. No description. I first tried to repair, then completely re-installed and still nothing. What am I not doing right? Here are the 2 screen shots. Whats up?


Hi Tom,

Try right clicking on “status” and select “Choose Columns…” mark sure the fields you want are check marked.

If they are check marked scroll to the right in eCatcher. your status field may be very large and pushed the rest of the fields off screen.

Yep. That’s what it was. The status was taking up the whole screen. Thanks