EC360 Firmware Update Error

Hi guys! I’m trying to update the firmware on all of my Netbiter EC360s to the latest version, 2.04.05, as requested. I am using a laptop with Windows 10, with a USB cable to do a local connection and going to and logging in, and doing the firmware update. Sometimes the update works fine, with no problem; but the next location when I attempt the exact same procedure, I get an odd error message that says “413- Request Entity Too Large”. I have tried exiting out of everything, rebooting, and starting over again, and it still does the same thing. What is going on?
Robert Akins

Hello @anonzwhgkqab ,

I have not seen this issue before. Are you sure you are using the same firmware file you used before? Have you tried a different browser?

Hello Deryck, I think I solved the first problem, but I have a new but related problem. I discovered that if I cycle power on the EC360, then do the firmware update, it works with no problems. However, now I am trying to update an EC350 that I want to repurpose as an Ethernet connected gateway. It currently has firmware version 2.01.01. When I run the update, it gives me an error message that says ‘Bad Signature’

You may need to set the data and time manually from the web GUI or connect the WAN to the internet for it to set automatically via NTP.