ECI Demo fail to find USBtoCAN device

Installed drivers from using “make install-usb”. Running the demos ./LinuxEciDemo from bin/release – they cannot find the device.

ECI Demo for USB-to-CAN compact <<
ECI109_GetInfo…failed with errorcode: 0xE0FE000E. The device or resource could not be found.

the ‘lsusb -t’ command does show the IXXAT device driver is loaded when the device is connected to the USB port.

IXXAT USB-to-CAN v2 Compact
Dell laptop amd64
Running Ubuntu 18.04

It’s possible you may need to update the bootloader. What is the serial number?


USB-to-CAN V2 compact

That’s the article number. Can you send a picture of the label? There should be a number that starts with HW…

SN: HW595096

Looks to be firmware v1.3

We are on Ubuntu 18.04 x86 architecture.

Image attached

Curious is there a version of drivers for arm64?

I think what might be happening is that Socket CAN is already implemented in the Ubuntu kernel and is taking over. Check whether the SocketCAN driver is loaded:

dmesg | grep ixx_usb

Unload the driver:

sudo modprobe -r ixx_usb

To prevent loading the IXXAT SocketCAN module at Ubuntu startup:

vi /etc/modprobe.d/blacklist-ixx_usb.conf'

And add:

blacklist ixx_usb

Not at this time. Currently just the x86 and AMD64.

There is no output from any of the following commands:

dmesg | grep ixx_usb

dmesg | grep ixx

dmesg | grep can0

Can you share the output of the following commands:

lspci -v

uname -a

dmesg | grep ECI

cat /proc/eci

lspci -v

uname -a
Linux ubuntu 4.15.0-1069-oem #79-Ubuntu SMP Wed Feb 5 13:48:18 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

dmesg | grep ECI

= no string found

cat /proc/eci

= no eci process

lspci (9.28 KB)

The Socket CAN driver is included in that kernel and will prevent ECI from running.

  1. Create a new file to prevent loading the Kernel driver at startup:
    File: ‘/etc/modprobe.d/blacklist-ixx_usb.conf’
    Content: blacklist ixx_usb

  2. Unload the current running driver without reboot: modprobe -r ixx_usb

modprobe failed with “Module ixx_usb not found”. Using lsmod, we do not see that ixx_usb is loaded, only the two related libs below:

ixxat_usb2can 24576 0ixx

can_dev 28672 1 ixxat_usb2can

Screenshot from 2020-02-18 06-59-58.png

lsmod (7.47 KB)

Can you connect the device to a Windows box and run C:\Program Files\HMS\Ixxat VCI\VCI4floadGUI.exe and take a screen shot?

Also, Are you trying to connect to a VM or physical computer?

Screenshot attached.

This is a physical device (Dell XPS laptop).

It does have USB 3.0 and it’s not able to throttle back to USB 2.0 in the BIOS. Running Ubuntu 18.04

It should be working with that version. Building the demo completed with no errors?

Is the USB-to-CAN V2 connected directly or via an USB extension cable or dongle?

Is the USB light on the USB-to-CAN V2?

Have you tried connecting the USB-to-CAN V2 via an external USB hub with an external power supply?

I just looked at the error you showed above again and noticed that is is for USB-to-CAN compact. That is an older version. It will try a bunch of devices, including that one, but then you should see something like this:

ECI Demo for USB-to-CAN V2 <<
HwInfoVer: “0”
BoardType : “USB-to-CAN_V2”
HwSerial : “HW503867”
HwVersion : “”
BmVersion : “”
FwIdentif : “BAL V3”
FwVersion : “”
EciApiVer : “”
DevId : “0x0”
CtrlCount : “2”
CtrlIndex : “0”
CtrlClass : “0x0001”
CtrlState : “0x0000”
CtrlIndex : “1”
CtrlClass : “0x0001”
CtrlState : “0x0000”

ECI CAN Demo <<
CapsVer : “0”
CanType : “0x000b”
BusCoupl : “0x0002”
Feature : “0x005f”
PriClkFreq : “1000000”
TscDiv : “1”
DtxDiv : “1”
DtxMaxTic : “0”
PrioQueue : “1”
Now, sending 20480 CAN Messages

Correct, USB-to-CAN compact and expect the output you show below only for Demo 109 which if for this device, but the GetInfo() is failing. We can see that there is no driver loaded until the converter is plugged into the USB port at which
point the ixxxat_USB driver loads.

Any further suggestions?

What I’m saying is that the demo will check for different devices, including the original USB-to-CAN compact. The error you pasted in the original post looks like it’s for the old version. The new one should say >> ECI Demo for USB-to-CAN V2 <<

Is the USB-to-CAN V2 connected directly or via an USB extension cable or dongle?

Is the USB light on the USB-to-CAN V2 green?

Have you tried connecting the USB-to-CAN V2 via an external USB hub with an external power supply?

The one I have says “USB-to-CAN V2 compact”, which is pictured on the home page

and is identified as the USB-to-CAN V2 compact D-SUB-9,

The Demo tests for three different USB-to-CAN devices and none find this device.

Kyle asked:


At this point I would flash with the latest firmware, 1.7 and then try again.

Is this USB LED green when you plug into the laptop?