I have an EWON COZY 131-3G, the same when I turn on the USR LED turns red and does not go out. I tried to reset to factory default but without success. I also tried to restore it through eBuddy but the program cannot find it either by IP or SN.
Any procedure?

It’s sounds like your only option at this point is to attempt the Ewon Recovery process. If this does not work when directly connected from your PC to port 1 on the Ewon, try using a 10/100 Ethernet switch in between them.

You will need to select Tools --> Ewon Recovery then enter the serial number and select the latest firmware. After clicking Next you will need to boot the Ewon while holding the Reset button and wait for eBuddy to discover it. Once it does, tap the Reset button twice to begin the Recovery.

If this fails, please provide the serial number.

Thank you,


I performed as requested but without success.
SN: 1547-0068-22.

Thank You!


It appears that the device will have to be replaced in this case as it’s over 5 years old.


I managed to perform the recovery, however in the end it generated a failure right after doing the procedure of pressing the reset twice.
I made a video of how the leds are doing. To see if there is anything to do.
I find it strange that this happened because I only used it three times.

out_2021-01-29-10-28-01.MP4 (1.8 MB)

I would keep trying the Recovery Process until it works.

Can your failure be recovered from your experience?


After trying to recover from another desktop, the attached message appeared.

Have you tried this more than once? Do you get the same error each time?

Do you know what is the original firmware that is on the device?

In subsequent attempts, this error is shown in the attachment.
I don’t know what the original firmware version is.
I believe you should never have undergone an update.
And the LEDs remain the same as the video

The only other thing that I could recommend trying, is to use and older firmware, like 11.2, for example.


See the attached video. I tried to update with version 12. It is possible to deduce what is happening

Please make sure that the network adapter on the PC that is connected to the Ewon has an IP Address in the 10.0.0.X/24 subnet.

For example:
IP Address:
Subnet mask:

Gateway and DNS not needed.


Yes, I did as you asked, but still you have the same flaw.

At this point I would recommend replacing the device. Most carriers are replacing 3G towers with 4G/5G ones now, so it’s nearing the end of it’s useful life as a cellular device anyway.


I got another VPN model x005CD, but it is not being used, but as I understand it at the time of configuration, it is associated with another account. I would like to delete this association in order to use it.
Could you help me?
Thank you

We cannot delete a device from a customer’s account without their permission. If the customer deletes it from their account, then you can register it.

If you provide the serial number I can check the registration status.

The serial number is: 1345-0110-57
Can you see the contact of the company that registered this equipment so that I can request the exclusion?

Sure. What is the name of your company? Are you a distributor?

I'm not a distributor. I am an end customer.
My company's name is "Fuzzy Controle e Automacao Industrial Ltda."