eWON Cosy 131 connection with sim card and layer 2

Good morning, I have a ewon cosy 131 configured with a sim card (no WAN connection).
The connection with eCatcher and the VPN work correctly, the quality of the signal is very good.
I have 2 devices connected to it on LAN port:

  • a display
  • a plc IFM CR721S
    I can ping both but I can’t connect to the plc.
    I tried with an other router (not ewon) and if I set its comunication to layer 2 everything work but the quality of the signal is very bad.
    Is possible to do the same thing with the ewon? Are there some specific parameters on the System cfg/COM cfg that could help?
    Thank you for any advice/idea.

Yes, to allow layer 2 traffic, you need to enable BroadcastForwarder. Change it from 0 to 1 in the comcfg file.

Thank you, I tried today but unfortunately it’s still not working. What could it be?

It’s very hard for me to say with just the info you have provided. It may be a timeout setting in the PLC or PLC software (you haven’t mentioned how you are connecting to the PLC, what software, what protocol, etc.).

It could possibly be related to the packet MTU size due to the VPN or cellular connection.

Also, can you explain this statement a little more:

What type of router? Was it also cellular? Was it also using a VPN? How do you determine the signal quality?

Can you provide an error log, screenshots, packet capture? Anything else to narrow this down?

I tried with a Z-PASS2 (Seneca), with the same sim card and apn, using a VPN. Atteched there’s a screenshot where you can select the mode LAYER 2/LAYER 3, and a list of the cofiguration parameters.
The quality of the signal is very bad because the ping takes over to 2000/2500ms. If I connect to an other device with the ewon (in the same place) the ping takes under 800ms.
The software of the plc is Codesys 3.5, but I don’t modify nothing if I connect to the device via ethernet cable or via VPN-sim card, so I think it’s a setting of the router/vpn.bridging layer 2 bridging layer 2_1 summary.pdf (110.4 KB)

What is odd is that you can ping the PLC, but you cannot connect to it with your software. That would indicate that it’s not a routing problem. We know there is a route between your PC and the PLC.

Is there a setting in Codesys for setting the network adapter to use? Maybe this needs to be changed to the TAP adapter?

You can also try setting the VPN to a TCP instead of UDP connection. In comcfg change:

 VPNProto -> 1
 VPNPortOut -> 443

In eCatcher, on the log in page, click Settings > ‘Connection & Proxy Settings’ and select TCP.

If the problem persists, I would recommend going to https://mysupport.hms.se to create a case. That will allow you to report the problem to our Ewon team who can provide more direct support to our EU customers. They may ask you to help them get a packet capture to exam the traffic that is being exchanged between the networks.

I tried but unfortunately it doesn’t work. Thank you for your advices.
I’ll go to the support. If I’ll solve I’ll write here the solution.

Thanks for the update.