Ewon Flexy Fails to Boot right out of the box

We have purchased Flexy 101 few years back and delivered to customer as box pack. Now we took out of the box for commissioning and realized that it is not booting. All 5 right side LEDs (Pwr, Usr, DI1, DI2 & DO) are lit permanently with Usr LED is permanently Red. For me it looks like searching for a boot / boot-loader.
Ebuddy is not able to detect the module and we tried recovery through ebuddy by entering serial number which didn’t work.
Tried factory reset using reset button and there is no effect on module as well.
We have 7 Ewon Modules which are under serial number 1542-xxxx-xx / 1551-xxxx-xx and all of these modules are having same issue.

May I Know what could be the reason for this issue. For me it looks like these modules are shipped from the factory without Boot-loader.
Further to this may I know why was the modules with serial number range 1537-xxxx-xx to 1605-xxxx-xx are eligible for returns as mentioned in post#4 of below link.


Please try the recovery process in the following post.

Solid red means it is having problems with bootup.

If it is still failing afterwards please create a ticket at mysupport.hms.se. There the ticket will be forward to the team that can assist if a return is eligible.

Hi Zach,
As of my understanding, I can perform the steps that Tim have mentioned in “General Upgrade and Recovery Guide” only if the device is detected by eBuddy or its IP can be set or ping.
As I have mentioned in post#1 the device is not able to detect using eBuddy and not able to set IP or ping the device on its default IP. I am not able to know whether there is a firmware or which FW version it have.
Please let me know if it is still possible to execute the steps that Tim mentioned.

You do not need to see the ewon in ebuddy or know the IP address to perform a recovery and can be done with any firmware the ewon currently has.
MicrosoftTeams-image (5)

You will need a 10/100 switch and a connection to port 1 of the ewon.

If this does not resolve the problem you please create a ticket on mysupport.hms.se

I didn’t understand this. I think, to right click on device it should appear on eBuddy. Any way I can go to recovery by menu “Tools > eWon recovery” or F7 hot key. This didn’t work even with a switch in between.

By the way I forgot to inform an important point. The network port itself did not power up because of missing boot.
Windows PC network adapter shows “network cable unplugged” when connected to eWon directly. Rx/Tx, Link LEDs in the switch port also not lit when connected to eWon port.
I will create a ticket at mysupport.hms.se. Thanks for your support.