eWON Flexy Java Hello Word

Hi, I’m following the guide eWON Java Toolkit User guide and I’m up to page 18, where you debug the code for the first time. I’m using Netbeans and an eWON Flexy 202.

Everything seems to have installed and compiled fine. Some parts were slightly different to the guide but seems to match up well, just looks like different versions.

However when I try to debug the hello world application, I get errors in Netbeans, and also on the eWON events page.


The eWON is connected over a VPN (workplace VPN), but the connection is very fast.
Looking through FTP I can see the files have successfully copied over when I click deploy in netbeans.
I’ve tried restarting the eWON but the same errors keep coming up.

Do you have any ideas?

Thanks a lot


Is there a chance you are running the newest firmware on your flexy (with the new GUI)? If so, try downgrading your flexy to an older firmware (12.0.0) and give it another shot. I believe there is a known bug in the debugging process for the most recent firmware.


What version are you running? As @nickTriPhase1 said you could be running into a bug with the the new firmware.



I was running the new software yes, I’m now using an eWON with 12.0s0 firmware.

The program seems to run ok, I can see the print output in realtime log, however I still can’t debug.

It says Execution Failed with error code 16 (Line 985 build-imp.xml) which is

        <nb-run debug="true" debugsuspend="true" debugserver="true" debuggeraddressproperty="jpda.port" platformtype="${platform.type}" platformhome="${platform.home}" device="${platform.device}" jadfile="${dist.dir}/${dist.jad}" jadurl="${dist.jad.url}" jarfile="${dist.dir}/${dist.jar}" execmethod="${run.method}" securitydomain="${evaluated.run.security.domain}" commandline="${platform.debugcommandline}" classpath="${platform.bootclasspath}:${dist.dir}/${dist.jar}" cmdoptions="${run.cmd.options}"/>

I also get this error in Netbeans, but I’ve put the breakpoint on a line that just says “x++;” which is definetely executable.



Right click on your project, go to properties -> platform -> Manage Emulators -> eWON JTK. Do you have the following sources imported?



No they weren’t include, I have included them now but still get the same errors




I don’t suppose it needs an import package?

The only import I have at the top is

import com.ewon.ewonitf.IOManager;


Try removing both the CDC and CLDC platforms so that all that is left is the eWON JTK and the JDK.

Where is your NetBeansProjects folder stored on your computer?

Make sure you have CLDC selected as well for the platform type:

I have to choose CLDC/MIDP or CDC so chose CLDC/MIDP.

D:\Documents\eWON Java\Projects\eWON_Java_Tom_1\

The error shows
D:\Documents\eWON Java\Projects\eWON_Java_Tom_1\nbproject\build-impl.xml:895:

But the javaetk files are in
D:\Documents\eWON Java\javaetk

Do they javaetk (including the source files for eWON JTK) need to be in a similar folder?

Thanks for all the help!

The location of the javaetk folder shouldn’t matter as long as you told Netbeans the proper place to look. I have my projects located in C:\Users\myUserDomain\Documents. I recall having trouble with the debugger before when changing the location of the project folder during installation. Maybe try reinstalling it all, but don’t change the file locations?