eWon Flexy201 losing modem/internet config

Hi Tim,
The first time these units were setup, they were configured to use the WAN connection as the primary connection, and the cellular modem was configured as the fallback (all done through the wizard).
After the units arrived on site, it was determined that there were no hard-wired internet connections available, so the Wizard was run again, and the cellular modem was set as the primary connection. The hard-wired WAN was NOT setup as a fallback. So even though a WAN card is in the eWon rack, it is not being used at all.
Thanks,
Mike

Hi Mike,

We escalated this to some colleagues in Belgium and they asked if you could upgrade the device to the newest firmware 14.2 to make sure that this wasn’t a bug that’s already been looked at.

-Tim

Hi Tim,

4 of the 5 eWons have been upgraded to 14.2. We still experienced the issue on TUV_ewon4 (which was at 14.2), it’s just the backup you have is from before it was updated. In addition, I spoke with Kyle on Thursday and he created a new ticket an issue with the opcua wd, which could be related. (New Case created with ID: 202007-17357 CRM:0033070555)

Mike

Thanks Mike,

That was where I read the recommendation from, I’ll check with Belgium when they’re in tomorrow morning and see if they have any other recommendations.

-Tim

We have been experiencing the issue on all 5 of the units. Currently, only 2 of them are installed on site and active. For these 2, 1 has the older firmware (ewon1), the other (ewon5) has gone through the recovery procedure and has the latest firmware. Both have been running since Monday with no issue losing the configuration; however, as you’ll see in the logs, they’ve both been experiencing the reboot watchdog due to OPCUA.

Mike

Hi Mike,

Sorry for the delay, We’re going back through and closing out all of the older support tickets and I must’ve lost track of this one. Is this still an issue?

-Tim

Hi Tim,

This is still a major issue for us. I attempted loading one of our Flexy units with the 14.3s0PR to see if it would solve the issue, but it was unsuccessful. Problem still exists.

To re-iterate:

The issue occurs if the Flexy is configured to talk to a PLC using OPCUA (so the eWON is the client) and the eWON is powered up when the PLC Ethernet cable is connected to the eWON LAN. When in this state, opcuawd errors are causing the flexy to reboot continuously; therefore, it never has a chance to establish an internet (cellular) and VPN connection to the Talk2M servers. If we unplug the PLC LAN cable from the PLC, and cycle power to the eWON, then the watchdog does not cause a reboot, and the internet/VPN gets connected. We then plug in the PLC, and all is good…until there is a power failure. Then we need to send a technician to site to get it up and running. Obviously, not a good thing for a remote device. Please let me know what your team can do to resolve this issue.

Thanks,

Mike

It looks like they had done some work in the 14.3 firmware revision on OPCUA but if that didn’t seem to fix it, I’ll need to bring it back up with Belgium

Could you send me another backup of the device with support files included that’s on FW 14.3?

Tried to email, but got blocked. Here is the backup with support files:

FYI, I upgraded the firmware on the 21st of September, and did testing that day with a technician on site. We weren’t able to get the eWON to establish an internet/VPN connection until we unplugged the PLC. He connected the PLC after getting connected to internet/VPN, and it worked for few days. The unit lost it’s connection to the PLC on the 25th of September. We haven’t been able to get a technician out to site since. Could be the LAN cable is unplugged, or another issue. I don’t know.

Mike

Ok thanks for the update, I’ll see if I can find anymore information about this in the meantime from Belgium

My colleague asked me to check this with you:

It is perhaps something caused by the script.

  • What if they disable the script (autorun) ?

  • They also do “IF a THEN” but this will be true when a = 1 (ok) and when a = 2 (comm not ok). So they should do “IF a = 1 THEN” to be sure to do that when the connection is properly established.

  • What if they disable the IOServer, reboot the Ewon and then re-enable it ? Does it make a watchdog as well ?

Hi Tim,

More info:

We can’t talk to the PLC. I thought it may be a cable issue. Turns out the connection is fine. I can VPN to the ewon and connect to the PLC with SSH and HTTP. In addition, I can use an OPCUA tool (UaExpert) to browse the PLC tags. I tried to browse the PLC tags from the eWON, and I have failures and none of the already configured tags are reading.

image001.png

I believe this may be an issue with the PR firmware.

Mike

More updates:

I’ve modified the script to use the a = 1.

I disabled the IOServer, then re-enabled. Now the tags read. I haven’t seen this behaviour before, so it could be something with the PR firmware.

I can’t try rebooting. No one is on site and it is too risky that the ewon won’t come back online. I will try these suggestions (disable the server, reboot, then enable) once I can get a tech on site.

Mike

Thanks for the update Mike,

When you’re able to get on site can you let us know what you find out

-Tim

Hi Mike,

Just wanted to see if you had an idea of when you might be able to check on these devices?

-Tim

Hi Tim,
We sent a service technician out at site this morning. We did the following:

A) Test 1
1) Ensure PLC cable connected to eWON
2) Confirmed that tags are reading
3) Confirmed that BASIC script is running and set to Autorun
4) Disable the OPCUA IO Server
5) Power off eWON, wait a few minutes, Power on eWON
6) eWON cellular and VPN come back online within a few minutes
7) Connect to eWON through eCatcher
8) Enable the OPCUA IO Server
9) Tags start reading and all is good

B) Test 2
1) Ensure PLC cable connected to eWON
2) Confirmed that the OPCUA IO Server is enabled and tags are reading
3) Confirmed that BASIC script is NOT running and Autorun is deselected
4) Power off eWON, wait a few minutes, Power on eWON
5) eWON does not come online and reboots
6) Physically disconnect the PLC ethernet cable
7) eWON established cellular and VPN connection
8) Connect to eWON through eCatcher and confirm that opcuacom wd caused reboot
9) Physically connect the PLC ethernet cable. Confirmed that tags are reading
10) Re-enable BASIC script

TUV_eWON3_07OCT2020.tar (214.5 KB)

It does not appear to be an issue with the BASIC script.

I’ve attached the backup (with support files). Please advise next steps.

Mike

Thanks Mike,

I’ll talk this over with Simon and see what he recommends

Hi Mike,

Here’s what I heard back form Simon, would you be able to do a TeamViewer session early in the morning so that we could work with the Belgian team?

"It would be good to have a Teamviewer with the local technician to see if we have some errors in the realtime logs (that we could not see in the backup due to the reboot).

A work-around that I am think to would be to enable the OPCUA IOServer after the boot using BASIC script :

TSET 4,60

ONTIMER 4, “GOTO EnableOPCUA”

EnableOPCUA:

SETSYS SYS, “LOAD”
SETSYS SYS, “IOSrvData1:EnabledA”, “1” //Check in the config.txt if it is well IOSrvData1 slot used by OPCUA
SETSYS SYS, “SAVE”

END

Could you also ask him the exact model of th WAGO device used and the firmware version ?

We may need to simulate that here to fix it."

Hi Tim,

*** Please do not post any of the below in the forum ***
[Information Redacted]

Thanks Mike,

I’ll check with Simon and see when he would be available to work with us on this