Flexy 205 Rebooting

Hello, I have a customer in the field with an Ewon Flexy 205 with a Verizon Wireless Cellular Module that started rebooting non stop. I assumed a software error so had him factory reset (Level 2) and reconfigure. Behavior continued, so I had him try to push the latest firmware update; same issue. He is using 24VDC so I don’t think it’s an overpower situation. I have just requested that he unplug the module as well to see if it boots normally to determine if it’s the base unit or the module. He is getting back to me on that. Any other thoughts on what I should do? Thanks.

Hi @rumsey-dk

If he powers down the device and removes the cards, does it still keep rebooting or does it only start rebooting when the extension cards are in the device? If you can get the device to turn on without rebooting, can you go onto eBuddy and get a backup of the device with the support files included and send that file to us?

He had said it reboots in both instances – with module or withou. I have reached out to him to get a Serial Number as well.

What is the USR Led doing? also are all of the ethernet cables unplugged as well?

I will ask him once he responds; fairly certain he is just looking for an RMA at this point, but I understand if we have to jump through these hoops first.

Before we can go through and recommend an RMA, we recommend trying a factory reset and a recovery to see if we can fix the device.

He has performed the factory reset per my instruction a couple days ago – was still rebooting. I had him attempt to update to the latest firmware and he was able to do that this morning.

That’s when he asked if he could get an RMA on it.

If possible, we’d still like to have him try and do a recovery if possible to try and re-flash the device

Is there any easy way to get him in touch directly with you and this case so I don’t have to relay information through him?

You could send him this link and have him comment on this post Flexy 205 Rebooting

Well, he is extremely frustrated at this point and wants me to continue to relay things. He has provided the Serial Number 1936-0040-24.

Can you provide the next steps so I can ask him to perform them?

Sorry about that, was he not able to comment on this post? Also were you able to go through the recovery procedure in this post: General Upgrade and Recovery Guide

Well he’s just frustrated. I had him go through an upgrade already but I’ll have him do a recovery.


Sorry about that, we just want to make sure that you don’t end up getting charged for doing an RMA on a device that was still able to be recovered.

Understood, Tim – rules are rules!

I forwarded him the information on how to go through Recovery and will await his response.



Ok thanks let me know what you find out

Hi Tim – still no good for this. Now he is at the point where he has to have a replacement tomorrow for deployment over the weekend. He also managed to have it running for long enough to capture an event log (attached).

Since he needs replacements for both the base and module by tomorrow and we only have the base unit in stock; is it possible for both to come out of the Ewon warehouse?

Andrew – just wanted you to know what was going on with this case.

Hi @rumsey-dk,

Was he able to try the recovery? He can submit the device for an RMA if he wants to its just we can’t recommend it for an RMA unless we’ve tried the process above.


He did state that he did. I did not see him do it however.

These were the instructions I sent him:

For Recovery: (Flexy and Cosy 131 Devices Only)

If the firmware is lower than 11.0, you could also try and perform a recovery on the device. To do this right click on the device and go to ewon recovery. After this enter the serial number (this can be done even if the device isn’t appearing in ebuddy by right
clicking on the screen and going to ewon recovery and entering the serial number).

NOTE: you will need a 10/100 switch between the computer and the device or the device may be damaged during this process. If you don’t have a 10/100 switch but have another cosy or flexy device you can still perform this by having your PC connect to port 1
of the working device and have another cable connecting port 2 of the working device to port 1 of the damaged device

After this is done you will need to go onto the firmware download link above and set the pcode to 21, pick your revision, set language to MA and go to flexy & Cosy 131 recovery. Once this is downloaded, you’ll need to go to your computer’s C drive > Program
Files x86 > eBuddy > Firmware > and then paste the ebu files in this location.

Once this is done, you should have the option to select the version of the firmware you want to download. It will have you then turn the device off and while the device is off, push down the reset key and keep it held down while you power the device back on.
After a few seconds you should see a prompt on the screen telling you to push the reset button 2 more times and then the recovery should begin.