FTP file transfer failing for .jar into /usr

I am trying to transfer a custom .jar file into the /usr folder, but the transfer fails with a “Could not start transfer” message in the FTP client. I have tried with both FileZilla and command line FTP and both fail in the same way.
I am logged in as adm, and the .jar file is 89kb. I can successfully transfer a text file of 95kb into the /usr folder without issue.
Firmware is 14.5s1. Any idea what the problem may be?

Have you tried using FTP passive mode?

Yes, below is the session log I attempted from WSL. I can put an empty text file of the exact same size without issue.

scott@PF1W81CL:~$ ftp -p 10.29.140.xxx
Connected to 10.29.140.xxx.
220 FTP Server ready.
230 User logged in.
Remote system type is eWON.
ftp> cd usr
ftp> put AqvClient.jar
local: AqvClient.jar remote: AqvClient.jar
227 Entering passive mode (10,29,140,xxx,140,209)
150 Opening BINARY mode data connection for '/usr/AqvClient.jar'
426 Operation failed
90868 bytes sent in 0.54 secs (165.4531 kB/s)

A byte-by-byte copy of the .jar file transfers fine until 70780 bytes have non-zero data.

After some testing, it looks like anything that resembles a binary file is not transferred.
Things that have failed:

  • A 1kb file of random hex data
  • A small 4kb Windows executable

This seems very strange. I would expect any type of file to be transferred.

Yes, any file should be able to be transferred, and I’ve never heard of this problem before, so I’m inclined to believe this is a network issue.

Are you able to test this when connected directly to the Ewon, or do you only have remote access?

I only have remote access at this time.

If you want to open a case at https://support.hms-networks.com, we can help you take a packet capture from the Ewon’s LAN. This may help point to the culprit.

We have physical access today, so we’re going to attempt a transfer while connected directly.

Great! If it works when connected locally, I think the next step would be to take a pcaps from the Ewon when remote. Let me know how it goes. I can send you a utility for taking the pcaps.

FTP transfers failed when connected locally as well. We got the same type of error when attempting to transfer files.

1 Like

Hi Scott,

Thanks for testing that. Can you create a ticket at support.hms-networks.com so I can send you the pcap utility?

I wanted to follow up with the solution that was found for this issue.
It turned out that the eWon local storage was full from logs generated by a local Java application. Formatting the local storage area resolved the transfer problem.

Thanks for the update Scott! Glad you got it figured out!