GSM Protocol error 23514 can't send SMS

@anontekcvsif
Please make backup with eBuddy and Include support files.

Good afternoon.

This is the backups of the three ewons,

the master receive all the information from the slaves and send the sms.

1.- master, get the information from 32 plc s7-300

2.- slave1, get the information from 32 plc s7-300

3.- slave2 get the information from 4 plc s7-300

And we have a part of the project like test for check the sms, this back up is backup ewon inimtec upload 09_01_2020 here we are using only one ewon.

Thank you!!

MOVED TO STAFF NOTE (46.5 KB)

MOVED TO STAFF NOTE (142 KB)

MOVED TO STAFF NOTE (385 KB)

MOVED TO STAFF NOTE (37.5 KB)

Hi Abdel,

Thank you for sending the backups. I did noticed that there are only about 14 hours of logs, and there weren’t any gsm errors during that time. However, I did notice a couple things I would like to address right away:

The modem firmware may require an update. Please download and follow the instructions in this file:

https://hms365-my.sharepoint.com/:u:/g/personal/kre_hms_se/EYQJdi0YJxFNvF7jjgiOrNoBDJ_9UiVgqX5JULu78b8tQg?e=qM42bD

Then use eBuddy to update to the latest firmware, 14.0s2.

Change the following settings in comcfg.txt:

MaxCallDur : 1440
CallAlloc: 0

When you are entering the phone number (241407xxxx,gsm,0) please trying adding the ‘+’ and/or ‘+52’ because it may be in the wrong format for Telcel (+241407xxxx,gsm,0).

If you don’t make any progress with that please go in the Flexy’s debug settings and turn on debugging for all ports like this:

Then send some SMS messages and immediately make a backup and email to me.

Thank you,

Kyle

Thanks for the support.

I have the last updated firmware v14.0s02 in my ewon and with the tool for fix the 4G North America extension card,. It shows “This ewon is safe (No fix needed)”

I had changed the MaxCallDur an the Call Alloc.

I Added the +52 but i have the same error

I also changed the debug settings but the error continues.

Here is the last backup with the changes applied.

MOVED TO STAFF NOTE (399 KB)

Did you try just adding the + ?

Are you using the Modbus IO server? If not, can you disable it please.

Do you have any other SIM cards that you can try? We may have to work with Telcel directly to find out what the problem is here.

Im using the Modbus for a comunication betwen ewons.
And im worcking whit a new SIM card, and now is working, but after some minutes im sure is going to be locked the sms service for this card.

The SIM card works for some minutes, and in this time i have tested with
(xxx3217398,gsm,0), and adding +52(xxx3217398,gsm,0). and everythings its ok, i also tested with 00(xxx3217398,gsm,0) and this doesn’t work…
At the end, I can send sms only for some minutes, after that the sms service SIM is blocked.

This must be a carrier (Telcel) issue, as there is no function in the Flexy to block SMS messages. Have you informed them what happened?

Hi guys,

Can you also clarify which settings worked for sending the text?

(1234567890,gsm,0) and (+521234567890,gsm,0) works?

But (001234567890,gsm,0) does not?

Thank you!

Kyle

Hi Kyle!!

I’ve done some research about the problem with the Ewon FLEXY 205 as far as I know TELCEL the carrier has a filter for VoIP lines, that in somehow it detects that you are sending SMS for some cels in some time it blocks the service, why I don’t know. Also there is a TELCEL plan for M2M communication, it’s a different service that allows machine to machine communication. In the Ewon the technical data says is a M2M router, so my question is what do I have to ask to TELCEL the carrier to contract the M2M line? If any specific requirement is needed. I hope you can help me.

Thanks in advance.

Well, that is very strange indeed. All you need is a plan with data and SMS capability. The Flexy uses ports 1194 or 443 for OpenVPN. You can let them know if you want, but I don’t know of any carriers that block those ports.