HTTP Direct Connection Failure (Server certificate verification failed)

Having an issue where every time I run through the T2M wizard that the Talk2M test and configuration fails at the HTTP direct connection.

Specifically it says:

“HTTPS dialog failed (Server certificate verification failed: certificate has expired, certificate issued for a different host name)”

I am using a static IP address, it does pass the test online address and WAN connection test, and it does pass the UDP connection test.

The Cosy 131 was firmware 14.3 and has been working for almost a year. Looks like it was first connected by my customer around the end of April of 2021. The last connection show in the log was from 5/13/22.

I was able to have the customer connect their computer to the cosy so I could update the firmware to 14.5 but this has not fixed the issue. I have also tried a level 2 reset on the device but am still running into the same problem.


What are the date and time settings on the actual Cosy?

Also what are you using for a DNS address?


Date and time settings are currently manually set to EST. When I did the factory reset I tried to check the “Update clock via NTP” and left the default settings. I then came across a post on while looking for a solution to my problem that mentioned the date and time settings so I manually inputted the time.

For DNS address I just had in for the primary and secondary. Again, this cosy was working fine set up this way for a little over a year so I’m not sure why this would have caused it to stop working all the sudden.

I would update the DNS to a public one of Google and

This should give the hostname for our Talk2m servers

Will do. I wont have access to the cosy until sometime next week. I will attempt this when I do and update this post after trying this solution.

Would it be better to check the “Update clock via NTP”?

I would update the clock via NTP. That way it remains at the most accurate time regardless of it being shut off or not.

Okay. I will make that setting change as well when I set the DNS addresses.


Adding the DNS addresses and setting the clock to update via NTP worked. Still not sure why it was working for a year with out any DNS addresses but my customer and I are happy it is working now!

Thanks for the help Kevin!


Happy to hear the issue is resolved.