IP is visible but ftp folder is empty

I have a Anybus Compactcom 40 Profinet Module. I can see the IP address when I scan using the HMS IPconfig tool but when I access the folder via FTP I see that the folder is empty and I get a NO ACCESS message from windows. So How can I recover such a module? Or is it bricked?
Thanks in Advance for your help.

Hello @Sandeep ,

What is the error message you are receiving? It sounds like the host application may have the FTP option disabled. If FTP is disabled the ABCC will refuse the connection. Each FTP client will handle this differently Windows explorer will show a message saying it cannot access the folder, WinSCP will show that it was actively refused.


This is the message I get when I try to open the folder using windows explorer.

Is this your device that the abcc is embedded in? Can you verify that FTP is enabled for the module?

Have you tried another FTP client such as Filezilla or WINscp?

Yes this is the device that the abcc is embedded in. FTP is enabled for the module. I have tried WINscp but I get the same result. Here is the screenshot of it.


What is the device it is embedded in? Are you the developer? In abcc_obj_cfg.h do you have the ETN_OBJ_ENABLE set TRUE? and is ETN_IA_ENABLE_FTP_ENABLE & ETN_IA_ENABLE_FTP_VALUE set TRUE?

Do you have an \ftp.cfg file setup?

If you are not the manufacturer of the device the abcc is embedded in you will need to reach out to them for details on how to FTP into the device.