iPC-I 320/PCI II driver issue?

I am trying to setup a system to program some AMC and am having trouble getting my card to work.

My card version is a single can channel and din-6 plugs for the can interface, it is marked iPC-I 320/PCI II

My first try was a W98 computer and I used VCI2 drivers, everything appeared to install fine but when I hit “Test” I get a “Board reset error”, see attachment.

I insured the IRQ was clear and the IXXAT program showed the same memory and irq information as device manager which said the device was working properly. I tried several of the slots and different irq’s, same problem every time.

My board also has a beeper on it which would beep on boot and when I tried to access the board via the test button so I know it was receiving data from the driver. I later learned that there was a program downloaded in the board the utilized the beeper and flipped the dip switches to default which kept the board from making any noise but still no joy.

I finally gave up on the W98 setup and built a XP system using VCI3 drivers, after everything was said and done, the V3 drivers give me the dreaded tick mark in device manager (Code 10). The V2 drivers install correctly (no tick mark) but the mon program does not show a board is installed. I again tried several slots and reinstalled the driver (forcefully) to both v2 and v3. I never got the V3 driver happy with my setup and when the v2 said ok I could not comm with the board using “Test”

Using V2 driver on Xp and turning on the program again with the dipswitch yields the beeping exactly as when I was using the w98 system, at boot and when I hit “Test” I am totally full circle and scratching my head.

Any help would be appreciated,
Jmayes Engineering, TN, USA

Hi Jeff,

What software are you trying to use with this card? It appears to be an obsolete card and I could only find limited information.

The following manual has information about the dip switches for switching between loader and application mode:

But as far as which VCI drivers and OS it supports I will have to check with the IXXAT team.

Yes, I have read the manual over and over before posting. the only thing it really tells me is that if dip switch 1 is on then it run’s application mode. if it’s off it’s in downloader mode. When on and running the application mode it will beep when ever accessed proving the drivers are talking to it in some way. When dip sw1 is off (download mode) I get the same errors without any beeping) and the card will not open for downloading. (using V2). V3 I get nowhere because of the code 10 from windows. It does however beep when there driver tries to setup if in application mode.

I am only trying to run the VCI mini-mon at present before moving on to anything else.

Today I built another computer from scratch with a win7 fresh load, then loaded VCI V3.5, booted with the card, the driver loaded and again I got the dreaded tick mark in device manager (Code 10). At this point I can only assume the card is bad.

Unless you can tell me there is a way to default the card I think something has been loaded into it that is causing the problem.


Here is some info from the IXXAT engineers:

  1. The iPC-I 320/PCI II shold successfully run
    with the VCI V2.16.2.6 under Windows 98 & XP and
    with the VCI V3.5.4.4543 under Windows XP/7
    (The VCI V4 does not support the iPC-I 320/PCI II anymore, becuase it is obsolete since 2017)

  2. The error message “Board Error! Error 0xE0010106 -DPRAM DRV: Reset failed” tells
    that the VCI V2 driver could not reset the microcontroller on the iPC-I 320/PCI II.

  3. Could you please let me know exactly which VCI V2 and which VCI V3 did you test?

  4. a) Is a standard or customerspecific iPC-I 320/PCI II used?
    b) Could you please send me a photo of the label on the iPC-I 320/PCI II?
    c) Could you please let me know the order number of the iPC-I 320/PCI II?

  5. Could you please send me the screenshot of the complete content (at the top and below)
    of the IXXAT interfaces applet in the control panel?

  6. Does another iPC-I 320/PCI II successfully run instead of this one,
    or you do not have any replacement?

  7. My card version is a single can channel and din-6 plugs for the can interface,

it is marked iPC-I 320/PCI II

Does the CAN interface board have a Din-6 connector instead of the DSub9?
Could you please send me a photo?

I did confirm your specific product number was covered on your driver page 1.01.0039.90003. I does have two 6 pin din connectors for the can however the board is single channel.
I have tried
v2.16 and v2.18 on win95 Pentium 3 board
v2.16, v2.18 and 3.54 on XP Pentium 4 board
v3.54 on Win7 sp1 on faster Pentium 4 board

Same results every time, the board will beep when driver tries to talk to the board when the application switch is on, stays silent when in download mode.

The V2.x drivers say they install correctly and I get proper i/o information and even my target program will make the board beep (AMC digiflex program) but all I get is comm errors. your test program say’s it won’t reset.

Under 3.5x I get code 10 in driver property’s and no other programs can attempt to access the card but when booting the computer when the driver tries to set up the board I get the beeps

I am attempting to get another board from the vendor, I am now assuming it’s bad.

The only thing I can think of is the application program in it is for another application (other then your drivers) but I assume in download mode I should get past the “Test” button and be asked to re-download the board which I can’t.

Thankx for any help you can provide.


Sorry back pix was select twice, here is the front

I believe these are custom boards made for a specific vendor and machine (Storz Endoskop), which could be why they are not working with the generic drivers.