Limit on size of .txt download of the Historical Logging Table?

historical

#1

Is there a limit to how much data you can download from the HLT all at once?

I had a customer email me asking for a copy of the logging data for the entire month of August. they log every 10 seconds. There are 5 tags in the HLT when I look at it. However, when I try to show data from 01/08/2019 to 01/31/2019 at 10 second intervals and then hit the download button I get this:

image

Then this after hitting OK:
image

And then that goes away after maybe 30 seconds.

So in order to download the data I had to set the date range to 3-5 days at a time and download multiple files and combine them


#2

Hi,

Have you tried getting this information using a script such as the following to email the data to yourself.

Function tagmail()

$EmailTo$ = "email@email.com"
$EmailCC$ = "email@email.com"
$EmailSubject$ = “historical table”

$EmailBody$ = “”
$EmailBody$ = $EmailBody$ + "Time: " + TIME$ + CHR$(13) + CHR$(10) // Gives the full date when this was sent

$EmailAttachment$ = “&[$dtHL $fnSomeIntegerReport.txt]”

$EmailContents$ = $EmailBody$ + $EmailAttachment$

SENDMAIL $EmailTo$, $EmailCC$, $EmailSubject$, $EmailContents$

ENDFN


#4

Would that send the entire HL table? If so, that will be way too big to attach afaik


#5

Specifying with a group ,$flA for group A, or tag name $tnTest for tag Test, will narrow the call. We have a block descriptor helper that can be used to create the file.

https://ewonsupport.biz/ebd/


#6

All the tags they want are in the same group anyway. I’ll probably just build the EBD to always pull 1 month of data. Downloading that much manually and combining it came out to about 20MB so that should be small enough for most modern mail handling services. Maybe I’ll just run it on a schedule so it emails them the data every week so they’ll always have the last 4 weeks worth of data on hand.

Thanks Zach


#7

I’ve tried repeatedly to test downloading HL or HT using the EBD helper. I’m connected via ecatcher and I’m giving it the eWON units IP address. It downloads a file but the file is always empty except for the headers.

This should give me the last 5 days of data, correct? I tried both 5 and -5 for the start time


#8

Ok I got the EBD right but when I put it in the planner and force it I get this:

No attachment, it just has the EBD text at the top.