M2Web VNC connection Error

Hi, I have a customer who receives an error that says “the connection has been closed because the server is taking too long to respond. This is usually caused by network problems, such as a spotty wireless signal, or slow network speeds. Please check your network connection and try again.” This is only happening on one PC and they have tried multiple networks as well as changing the connection from TCP to UDP. The VNC connection previously worked and that suddenly stopped. Could a Windows update be causing this problem?

Hi AmandaF,

It sounds like your customer cannot connect while using one specific computer, regardless of the network it’s connected to. Is that accurate? Can they connect to any other devices through M2Web? Can anyone else connect to the device they cannot connect to?

It may be that a Windows update changed this computer’s firewall settings. One or more of our servers being blocked could explain the issue, as the customer may be able to connect to the main M2Web interface, but the connection fails to make it through to the device, causing that error. Can your customer try running the Talk2M Connection Checker? This will verify their device can connect to our servers.


That is correct. Customer ran the connection checker and it was successful.

Are they able to connect to any other devices through M2Web? At what point does this error happen? While they’re trying to connect to a device connected to an Ewon through VNC in M2Web?