Module info provided by JSON with Common Ethernet


“Network Guide Common Ethernet” declares a “networktype” element of the GET module/info,json, returning the byte ID of the network protocol. But executing this on the module doesn’t show this element. I have compared using a B40-PIR, this shows the entry.
Can you confirm this difference?

Regards, Thomas

Hello @ThomasK,

I believe this is the same on all Ethernet devices. I ran a quick test and I am seeing the networktype parameter for both Profinet and Common Ethernet.

Hi Deryck,

please excuse my late response - due to holidays and other project priorities I missed to track this…

I tried again now and reverted my code changes (names and version settings) to be comparable with your output.
But the networktype parameter is still missing. May this caused by the older version I have on HW (see screnshot attached)?

Regards, Thomas

Hi Thomas,

You are most likely right. Updating the firmware to the latest should resolve this issue. You can reach out to your local Support team via and request the most recent firmware to update your device.

Devices from our warehouse would come with the latest firmware unless they are special firmware locked versions.