MQTT script not connecting - WAN Interface not yet ready

hi all,

I’m running the sample program.txt provided on on my Flexy script.
I try monitoring the data published on the Ewon MQTT broker, but it never shows any information. After a few seconds I will get error 28 on the BASIC IDE console ‘WAN Interface not yet ready’.

Am I missing some configuration here?

I’m already reading tags from an OPC connection on the ‘Values’ tab, but I don’t know how to add them to the message to be published in the script, or if the GETSYS Tag is enough to add it to the message.

Any guide will be greatly appreciated. Thanks!


How are you connecting to the broker and what kind of authentication are you using?

Can you provide a backup of the Ewon (created with eBuddy) and include the Support Files?

I’m just copy pasting the script provided in the ewonsupport link. for some reason, it is always showing that error.

Is there a way to send you the backup privately?

The backup (.tar) file is automatically hidden from public view. Only HMS Support can see it.

Also, please provide some info about your MQTT broker. Is it local? Is it on Azure or AWS? Etc.

Thanks Kyle, I’m attaching it now, together with the script as saved from the BASIC IDE

So I just tested the same script myself and it’s working fine…

Is there a problem with your internet connection? You need to make sure that TCP port 1883 is open on your local network.

I’m told the port is open since it is being used for another transaction.

Is there a chance I’m missing some configuration for the WAN Interface? Is there a procedure that needs to make this error go away?



If that port is being used for something else than it might not be available for MQTT. What else is using TCP 1883?

You have finished the Internet Wizard, right? That’s all that MQTT needs to function for this script. The globe icon should be green:


You could make a backup of the Ewon using eBuddy (without the Support files) and then factory reset the Ewon (hold reset button for about 35 seconds while the Ewon powers up until the USR LED flashes red and then turns solid red - then power cycle) and try the script on a fresh configuration. This would let us determine if it’s an issue with the Ewon settings or not.

thanks Kyle,

The WAN interface is properly configured then. I’m double checking with my IT department if the port is open. I’ll keep you updated.


If you can, you can also potentially rule out network issues if there is another network to test it from, like a wireless hotspot or home network.

To try to rule out configuration issues, you could try the factory reset method that I mentioned.

thanks Kyle for your support. The port 1883 was blocked by IT. They opened it and now we were able to access to connect to the broker and read the tags.

Thanks again!


OK great - thanks for the update!