MTCP Red light blinking on HMS-EN2MB-R


#1

I currently have an Anybus HMS-EN2MB-R and I have transaction error i.e. if I try to do transaction monitor it shows error for all I/O data. Also, the data tags associated with the device don’t seem to be receiving data to them.

Thanks,
Arjun


#2

Hi @krarjun94,

Are you are following the Step by Step guide?

Can you send the configuration or screen shots? What are you trying to connect to on the Modbus network?

Kyle


#4

Hi,

PFA my configuration. It’s based off information from pg46 of the attached PDF. On the Modbus side we have an Chromalox Heat trace panel.

IM-PK497.pdf (9.25 MB)


#5

#6

It looks like the issue is errors in the modbus commands. Keep in mind that those registers are 2 bytes and the Range column is just the range of the actual data value that will be in the registers. Try adding one command at a time so you will know which one is causing the problem. If yhou are still having issues we can with you on Monday.

Kyle


#7

Would the errors in the modbus commands cause all of the data to be errored out? As you can see, there are a number of transactions in the image above and all of them are shown to be in error. Another question is, should the modbus registers be accessed in any particular order? Because I have accessed “input registers” “holding” registers before “holding” registers and some of the holding registers I have tried to read aren’t in order- for example, “Enable_Disable” registers are address bit 1009 and I have tried to read them after “Auto_Manual” whose address bits are 1081.


#8

Yes, I’m not sure if they are all wrong but one error can cause the others to error as well. That’s why I recommend testing it after you add each command. The modbus registers do not need to be accessed in any particular order by rule. I’m not sure what you mean by:

Can you clarify that a little?


#9

Hi Kyle,

I was referring to the registers not being accessed in order. So far, I’ve figured out that the MTCP error is due to the usage of “Read/Write Multiple Registers” (code 23)Modbus-TCP function with Start-up Mode set to “Directly”. However if I set the Start-Up Mode to “Wait for Data” the changes that I make don’t seem to take effect.

Regards,
Arjun


#10

If you are asking about the order of commands, you can run your commands in any order. It doesn’t make a difference. If you are asking about reading multiple registers in a command, yes, they have to be in order. You enter the starting address and the number of elements, in your case, the elements are 16-bit unsigned integers. So, using your first command in your screenshot as an example, you are trying to read the registers starting at Address 1 and consisting of 72 elements, so registers 1 through 73 will be read.

Can you provide a log of the Modbus communications? Do you have the user manual and register map for the Modbus device you are connecting to?


#11

okay, I still get the MTCP red light if I try to “read/write multiple registers” with start-up mode set to “directly”. And if I change the start-up mode to “Wait for Data”, then none of the changes I make seem to have any effect. Please find attached the user manual for the Modbus device I’m trying to communicate with-on page 55, you can find the holding register map.
IM-PK497.pdf (9.3 MB)


#13

Hi Arjun,

One thing you could consider, if the Anybus cyclically updating the value is causing the manually entered value to be overwritten, you can change from cyclical updates, to ‘On Data Change’. This way, the value is only written when it’s changed and the value won’t be overwritten cyclically. To do this, change the Update mode in the settings for the Query.

Kyle


#14

Hello Kyle,

Does the software “Anybus configuration manager” require a Anybus communicator hardware or how do I use this software?

Regards,
Arjun


#15

Yes, the Anybus Configuration Manager is only for use with the Communicator device. Please try what I suggested in the last post, it should resolve your problem:


#16

I don’t have an anybus communicator device. All I have is the " EtherNet/IP to Modbus TCP Linking Device". Do I simply plug it into this and use the software mentioned above?


#17

Sorry, wrong screen shot - same concept:


#19

I’ll try this out and let you know soon. Thanks!


#20

Did that work out for you?