Need help to ping to behind client IP

Ive already able to use NAT 1:1 and use the mapped ip of behind client devices, like in this image

This is my Flexy’s Routing config

I have set up a VPN with eFive, now i want to ping to the real address of behind client devices from eFive’s LAN. I have set NAT on LAN on Flexy but things seem to not worked yet.

P/s: i have used NAT 1:1, it worked fine. Just dont know how to ping its real address


The way you have it setup right now, you won’t be able to ping its real address. You’ll need to set it up to use NAT 1:1 on VPN. Since the devices that you’re trying to reach are the same IP address and are in the same subnet, there’s not way to differentiate between which device you’re trying to connect to and this will cause issues with the eFive. Please reference the guide below that goes over connecting to devices that have the same IP address.


Hi Tim
Thanks for your response, i have done it with NAT 1:1
So do you have any doc or guide how to set up to read its real address from eFive?

You won’t be able to read the real address since they’re all using the same address. You need to use the natted address.

I mean beside this case

Each Ewon that you’re connecting to needs to be on it’s own individual subnet.

Ewon 1-
Ewon 2-


In the picture above, the network you should be able to reach behind the cosy would be everything in the with at subnet mask.


Another question, I used NAT 1:1 on eFive.
I can ping the mapped ip when directly connect to LAN port of eFive (have to change my PC’s LAN ip)
But when i use eGrabIt, how can i be able to ping to the mapped ip? (right now i cannot)
I used static route but nothing change

Hi Tim
Thanks for your response
It looks like this problem occured because i havent checked the “Allow traffic between clients” in VPN Advanced Settings

Hi Phi,

This may help:

If the SCADA can access the PLC behind the eWON, then you have already configured the parameter “Network behind client” with the eWON LAN network in the account settings. Right ?
Then, the problem is maybe that the route to this eWON Network is NOT added to your PC when you use eGrabit.
If can happen if you, for example, check the option “Don’t push any routes to client” in the Account you use with your egrabit connection.