ONSMS not working

Thanks @mcn

Let me know what you find out

Hello, just saw the backup you sent me.

Did you mean that you put the backup of the working device on the one that you were having issues with and then it still wasn’t working?

That is correct. I developed this script on the first Flexy that we bought. It had the Verizon LTE card installed. I had the script working, able to send and receive text messages. Then we needed to loan it out to a customer, so I made a backup before reconfiguring it and sending it out. The script needed some slight modification to work with other carriers, but it has worked well for T-Mobile and Rogers.

One thought I had today and haven’t had the time to try was a SIM PIN. I don’t recall needing one for the first Verizon LTE card that we used, but I did seem to need one for this LTE card. In the Verizon status page, it says there are 2 PIN numbers. I want to try the other PIN to see if it makes a difference, but it seems odd that I can send SMS messages, connect to the Flexy, tunnel into the controllers, etc. if I wasn’t using the right PIN.

Any other suggestions?

Mark Needham Control Systems Integrator

Any chance there’s any restrictions on what this SIM card can do? Did you have another SIM card that you were able to try on this device?

We were able to try with another SIM card, with no difference. Our HR director manages the cellular accounts and we have gone over the device information for both SIM cards. There shouldn’t be any restrictions on the SIM card.

I removed the Verizon LTE card, did a level 2 reset, and setup the Flexy again. I tried my script again and had no luck. I also tried the example ‘Sending an SMS receipt to the SMS sender’ in the ‘SMS reception with eWON’ KB pdf. No luck there either. I can do a SENDSMS from the console, but the script doesn’t respond when running.

I have the latest firmware installed, 13.3s0. I believe this is newer than the other Flexys that this script has worked on, but they are offline right now so I can’t check. I wanted to try downgrading from 13.3 to 13.0. I tried using the eWON recovery to do so, but that doesn’t see the Flexy after I reboot when prompted. I do have the computer connected to a switch, and not directly to the eWon. The network cable is plugged into port 1.

Hi Mark,

Can you try and go through the recovery procedure described in the doc below and if you have issues getting it back onto FW 13.0 give me a call at 312-893-5636?

One other thing I’d like to try would be to send the SIM card to the working Flexy and see if you can get that to work, or if you have another Verizon 4G card available that we could try on this device to narrow down if it’s a hardware issue. I’ll check with some colleagues and see if this is an issue they might have seen before

Hi Mark,

I just checked and one of my colleagues had another idea to debug this. Can set these settings under the debug menu and then try sending an SMS to the device

Hi Mark,

Sorry for the delay on this, we went out and bought a Verizon SIM card and are trying to figure out what is going on with this issue. We’ve been able to replicate the problem that you’re seeing so hopefully we can find a solution to it quickly


Thanks for the update. I was able to get it working late this afternoon with a FLB3205 and an AT&T SIM card (it didn’t have SMS enabled initially). I noticed that when it started working, it went to the Testing() function first, and skipped the ‘Goto HSms’. When I commented out the ONSMS “@Testing()” line, it did go to the HSms routine. It appears that the messages were in a queue as it responded to several of my text messages at once. I’ve attached the program and a couple of screenshots from my phone.

This will work for the interim, as this particular Flexy is for a show next week. We will still need to figure out why the Verizon one isn’t working, as they are the carrier that we normally use.

Thanks for your help, and please let me know what you find out with the Verizon card.

Mark Needham Control Systems Integrator

Flexy SMS Test Program2.bas (988 Bytes)

Hey Mark,

Can my colleague in Belgium and I jump on and take a look at this device that had the Verizon card connected to it again sometime tomorrow morning? He wants to see what information the device was giving when it was receiving the wakeup SMS

Unfortunately I don’t think we will be able to in the morning. The panel is scheduled to ship at 9am. We could set something up when the panel gets back in a week or two. We will still need this to work with Verizon for upcoming systems.

Ok if you could send me a response on this when you’re free, we’d like to look into this with you

I would like to resolve the issue with the Verizon SIM. I created another thread that is identical before noticing this conversation with Mark. Can send SMS messages with the Console or script but the ONSMS is never triggered when a message is received.

Hi @Tmurray,

I’ll check with the developer and see what I can find out


I have two Flexy(s). One shipped to a customer with a T-Mobil SIM and it will send and receive SMS messages. They want me to replace the SIM to a US Cellular. I and not able to get it working yet. Always getting a sms-GSM Protocol Error (6). I upgraded the firmware to 14.s02 from 13.3s0 but still errors.

The second one has a Verizon SIM and it sends but never initiates the ONSMS event for the program. I simply put a Print “Here…” statement to see if the event occurs and it does not. This is the error Mark was reporting. Just providing more info and letting you know I have 2 flexy, 3 SIMs and 2 cell modules (FLB3203 & FLB3205). Verizon is on the FLB3205. The other two are being swapped in FLB3203.

Hi @Tmurray

I’m working with a developer on this right now for the Verizon one. With the US Cellular device, do you know if he was able to get the device online in eCatcher yet or is it still failing that wizard?

I contacted US Cellular and they said the IMEI is not compatible with SIM (this one happened to be a pre-paid phone SIM). So I am checking for options with US Cellular plans.

US Cellular is not an option so trying to see if one will work. Only connection needed is SMS so Internet is not required but is included with the SIM. Tried T-Mobile with APN of internet but failed with eer-Assert: Invalid parameter (Id:).

Hi @Tmurray

With T-Mobile the APN may have been something else. These are some common default APNs for T-Mobile, but if it’s not working with one of these, you might have to contact them to see if you have a custom APN.

I may have not been clear. When I tried setting up the US Cellular the Wizard for United States list various cell companies but did not have US Cellular as an option. So I selected (or kept) T-Mobil and used what I thought was the APN for US Cellular (internet). But it did not work. The T-Mobile SIM is configured correctly. When I called US Cellular to get the APN I was told that the IMEI number was not comptable and that they could not move the phone number from the cell phone to the Flexy. Now I am just trying to get a US Cellular plan and SIM that is compatible. That’s the direction I am pursuing now for the Flexy system not using Verizon. Any information is appreciated so thanks for your research and replies.