OPC UA Communications Not Restored after Power Loss

I have the Flexy 201 and use the OPC UA I/O server to connect to a remote OPC-UA Server. I can setup the tags and easily see the tags from the remote OPC-UA Server. Everything looks good and the data is updating as expected with no problem.

However, when I cycle power or there is a network interruption, the Flexy 201 OPC-UA communications do not automatically return after power is restored or network is restored. For the tag to return to normal communications, I have to edit the OPC tag by changing the namespace from -1 back to 5 within the Flexy 201 Values screen. After I do that, the communications return and function as expected.

I have F/W 14.0s02

There no security settings on the UPC-UA server that I am connected to.
I change the Global Setting within the I/O Server to ‘Disable Tags in Error’ but I still have the same problem.

Hello Marty,

Per our phone call, I am going to update the escalated ticket and see if our development team has anything new regarding the OPCUA address changes.

Please let me know if you don’t recieve an email by the end of the day regarding an update on this topic/ticket.

I’m also having this problem.
I have seven Flexy205, and one Flexy201.
I read tags from them using a OPC-UA client.
Two of my Flexy205 has this problem.
The two Flexy205’s who suffers from this problem has Firmware 14.0s0PR (#895) and 14.1s0 (#1076). The Flexy201 and four of the other Flexy205’s has Firmware 13.0s0, and one has Firmware: 13.2s1 (#657). None of these devices suffers from this problem.
The fastest way I’ve found to get the communication up and running is to disable OPC-UA server and then enable it again.
Has this problem been fixed in newer firmware? I haven’t been able to update the firmware of these devices yet.

These issues were addressed on the latest firmware.

I would update to 14.2 and verify the connection again.

Mathias - The one thing that we found is that the name space array can not contain any blanks. I believe this was a bug that the EWON technical support team were aware of but at the time (Feb 2020) didn’t have a fix for yet. For us to get our system working as expected, I had the vendor update their I/O Server (not the EWON) to update their name space array to remove the blank (Specifically on ours, we had a value in name space array value 0,1,2,3, and 5. But 4 was a blank. When we update the I/O server to remove the blank in 4 everything worked as expected.

Hi there,

We are experiencing the same issue.
We have one ewon connected to 3 separate rittal iot interfaces (for chillers)
OPC comms cans be setup and works well but if any device loses power or connection then the OPC link is broken and will not reconnect.
I have tried firmwares from 14.0 up to 14.3 with the same issue

To reconnect i have to go into the values page, (tag configuration) and reselect the same io address from the prompt and the communication will return

i dont have any security on the opc and the “disable tags on error” option is not selected
I am not sure if there are blanks in the namespace array…

Is there a known issue with this or a workaround?

Do you know has there been any further info on this, the solution is marked as the flexy cannot deal with gaps in namespace array?


I would check the namespace array and ensure that are no spaces.

As for the disable tags in error. This is applied on the Flexy unit itself. This allows you to narrow down which tags are not functioning.