Operation failed: MQTT Connect (TLS/SSL related?)


I know there are already many MQTT related posts in this forum but none of the proposed solutions seem to work.
In our company we produce serial machines and use the same configuration for all machines.
The configuration usually works every time. But this particular Ewon just won’t connect to our Azure IoT Hub. The device is registered there, the device-ID is correct, I forced Google DNS Server on Ewon, tried different connection methods…

Error messages in BASIC IDE:

Error Messages in Event Logs:

At the moment the Ewon is connected via GSM.
But we have also tried the company’s Ethernet (resulting in the same error messages).

What is weird is that I can’t connect to the Ewon with Filezilla because “FTP over TLS is not supported”.

Do you have any idea how to fix this problem?

(And is there a possibility to check the files on Ewon via web interface? Unfortunately, the machine is on a different continent and I can’t connect locally)

Thanks in advance and cheers


For an issue like this, we advise creating a ticket on our Support Portal.


Our engineers may need to review the configuration, BASIC IDE, and investigate the cellular provider.