Power up issue Anybus X-gateway

We are currently using Anybus X-gateways to connect our robot systems to production machines. We are using the AB7800 Profibus DP Master to Ethernet IP Adapter gateway. We have a couple of those systems installed in the field and they are working. We noticed on the last few units we built that in about 1 of 5 power ups the Profibus side of the gateway goes into a stop and doesn’t connect to the network.
A new restart usually fixes the problem. I tried different settings on the Profibus and EthernetIP configuration but so far without success. What I noticed this morning when I was logged in over HyperTerminal that the module itself keeps hanging during the boot process.
The log file shows following error after it occurred
Like I said once the gateway successfully powers up everything works fine. It’s only sometimes it fails and we noticed this problem on multiple devices.


I apologize for the delay, I had though I sent some questions but it was still sitting as pending.

I had already escalated this to my colleagues and it looks like the firmware has been corrupted on the device or possibly failure in the flash. We can try updating the firmware to get the device operational again.

Here are instructions and the firmware file needed to update.

  1. Connect the Anybus X-gateway with an USB cable.
  2. Start “Firmware download TP” program
  3. Follow the instructions in the “Instruction” window to upgrade the software. When the question of target comes choose “Carrierboard”. When the question of version comes up please choose the expected target hardware and software to be downloaded. The file that should be downloaded is the fwp file (Firmware Package) file.
  4. A power cycle is required after the application has downloaded and the gateway self reboots.
  5. If the download is successful a window indicating “Transfer OK” will be displayed

FWP_ABX_V_3_29_01_D.fwp (73.6 KB)

Hello deryck_hms

No problem, thank you for your response. I tried to upgrade the firmware but it always stops at about 75% of the download. I tried about 5-6 times without success. After rebooting it shows an error message about a corrupt file system. Any further advice appreciated.

It looks looks like this is part of a hardware failure with the file system unable to recover. If the device is in warranty it should be covered. You can find more about the return process here

and the warranty policy here https://www.anybus.com/support/product-returns/product-return-policy

In your original post you mentioned the last few units, do you have multiple devices displaying these same symptoms? If so we might need to look into this a bit more to see if we can find the root cause.


Thank you for your reply Deryck. Yes, with have multiple devices showing this issue. At least 2 what I know. One of them is already in the field anther one is still in our facility. We have 3 other devices installed in the field but I haven’t heard any complains. So I do not know if these devices show the same symptoms or not. It only happens from time to time. I have another device in our facility I can test and check the firmware version. Thanks


Meanwhile I was able to install the firmware successfully. The version screen shows now 3.29.1 instead of 3.28.1 I don’t know what it was exactly but I tried to remove all other USB devices and disabled the Wifi. Unfortunately after about 12 shutdowns the issue occurred again. IMG_6008
Please ignore the first log entry this is occurred during the failed firmware upgrade.

Hi @astoneye,

How frequent are the devices being power cycled? If you are power cycling it very often you might be exceeding what the designers intended.

Can you provide additional serial numbers for the other devices experiencing the issue? I see this one has a0358ed1.


Hi Deryck

The customer runs an 8h shift per day so that’s one power cycle per day. Since the power failure happens about every 6th time it’s once a week and that’s where our customer started complaining about. The other problem is that another system in our facility shows the same issue that’s where I am doing my test (Ser. No. a0358ed1) and this unit is going to the same customer. That’s why he wants us to fix it before we ship it.
Unfortunately I have nobody at the customer at the moment to check the serial no of the other unit. But I will see if we can get it next time we have a technician there. Thanks.

Hi @astoneye,

One powere cycle a day should not cause any issue.

I want to confirm that you just have these 2 devices showing this issue and what similarities they have. Are the on the same machine design?

Are we sure they are having the same issue? In your first post you said " A new restart usually fixes the problem." If just a reboot is correcting the issue a starting to wonder if the firmware is the real issue. Perhaps just an issue with this device. Would there be any way to check if the device at the customer site shows the same boot failure as the one in your shop.

Hi Deryck

I agree one cycle a day should not cause an issue. I talk to another customer where we have 2 units in the field. He also noticed the problem. So at the moment we have 4 machines identical designs and identical devices showing this issue. So once in 5-6 restarts the gateway doesn’t boot and connect to the Profibus. After cycling the power it usually connects and runs without issues.

Hi @astoneye,

This is shaping up to be a case that I need to get people involved from our Swedish team. I am creating you an account and a case in out support system mysupport.hms.se so we can better manage this case. You should see an email regarding the case. You should be able to log in with your email, if it isn’t automatically send you will need to request a password recovery to set a password.

To recap the issue you have the profibus scanner setup and periodically (1 in 5) it will reboot and not connect to the slave nodes.

Do you have the control&Status word enabled? If so what status does it have? Do the nodes that you are connecting to provide any status info? What do they report?


Hi Deryck

Thank you for your reply. Yes, we have the Profibus DP Master and EthernetIP Adapter gateway (please see network schematic below). Network
In 1 of 5 cycle power we get the situation that the Anybus gateway keeps hanging in the boot process and does not connect to the Profibus network. Status and Control words are disabled at the moment because we are using the DP/DP coupler status words and I couldn’t get it to work with the 2 status/control words enabled. After an unsuccessful boot of the gateway the DP/DP coupler shows an error status on network 2 (not connected).

Hi @astoneye,

To get the device working again are you resetting it by power cycling it or does it require you to re-download a configuration?


Hi Deryck

It only needs a cycle power to recover. No reconfiguration needed.



I am reaching out to my colleagues in Sweden to see what tests we could run. We might need to find some way to consistently recreate the issue and monitor the traffic to check if we are sending any erroneous messages.


Hi @astoneye,

I have been discussing this with my colleagues in Sweden and we are not sure what would be causing this issue. It might be something specific to your network configuration. what are you using to bias your network?

Would you also be able to get a video of the error happening. I want verify the LED patters you are seeing. I am working on setting up a network to work though a few scenarios to see if I can trigger the same errors.


Hi Deryck,

What I can say about the network configuration is that we are using a Siemens DP/DP coupler part no. 6ES71580AD010XA0. On the Ethernet side the gateway is hooked up to a Fanuc R30iB Mate controller. The only hint I have about this error so far is the log file entry “Fault: Filename: abi/abi_upper.c Line nr. 02329”. The machine is running production now but I will try to shoot a video later of the failure and will get back to you. Thank you for your support on this issue.

Hi @astoneye,

Thanks for the update and for you patience with this issue.

I am not sure if that error is having any effect on this issue. You said you are just resetting the device to correct the issue. If the file missing was the issue a reboot would not correct the problem. Could you verify that on any other device having the issue?

I would also be curious if just unplugging and re-plugging the profibus cable has any effect in clearing the error. This might give us a better idea on what is causing the issue.