Serial communication dropping out

Customer is having issues with their serial communications dropping out randomly when they are trying to connect to a MLX PLC. Their logs and DF1 server settings are attached. The event logs seem to indicate something is not setup correctly. However, they have assured me that their PLC communication settings match the Flexy IO Server settings.

WHat are the settings for the PLC?

Also, can you provide a back up with support files?

Sorry for the delay - had to get them to let me back on.

PLC settings
DF1
Baud: 19200
Node: 1
Full Duplex

@Kevin_hms
Could you discern anything from the backup files? Is there any other information I could get for you?

Hi Auston, Chris Biester said you were looking for help. It looks like they have the wrong port settings. Can you make sure they have the FLA 3301 dip switches set to match whatever standard (RS232/RS485) they are using?

@kyle_HMS
Kyle, the RS232 indicator LED is lit so I believe they have that set up correctly. They have also tried using port 2 and they are getting the same issue. They can connect but it drops out every 6 or so seconds.

The picture above shows the error “Half/Full Duplex does not match the port config” but maybe that was before?

Another thing to try is using a null modem cable or adapter. Basically switching the RX and TX on one end.

Are they trying to read a tag? Or what exactly are they doing to test the connection?

I think they are just trying to go online with a MicroLogix processor and they can connect, but then it drops connection.

Try switching the the serial cable as well, and also use Kyle’s suggestion above:

Another thing to try is using a null modem cable or adapter. Basically switching the RX and TX on one end.

@Kevin_hms

Kevin,

They apparently do not have a null modem cable to test with. Is this the only thing we have in terms of solutions right now? If we get far enough down the rabbit hole would I be able to forward you their account info so you can log in and take a look yourself?

Thanks,
AD

Hello,

Yes, I would try the Null modem. If that doesn’t work. I can take a look at the unit myself for connectivity issues.

@Kevin_hms

Kevin,

They purchased a null modem cable and tried that. They said when it was connected they couldn’t see the PLC at all. I will message you with account details so you can take a look.

Hello,

I see that you have the ABLogix IO server and the DF1 IO server on the same COM Port. I would try disabling the Baudrate for the ABLOGIX IO, and/or move the IO to a different port. They could be conflicting as well.

@Kevin_hms

Kevin,

Looks to me like the DF1 and ABLOGIX mirror each other. On the ABLOGIX page it says COM Setup (Duplicate of DF1 IO Server). Any change I make to one makes the same change to the other. Not sure how I am supposed to disable one without the other.

Hello,

Another couple things i have noticed is the following:

The GSM level is very low (12), also when i tried to ping the LAN unit I was getting a couple second delay. Our required GSM level for stable connection is 18. The delay for Micrologix, could be resulted from dropped packets.
Also, i did see the following error:

pccc-The request was refused by the server (16-16) EIP

This error only happens in few instances.

However, I have not seen the original errors occur on the unit this week.

PCCC- could not open port or resume DF1
eserial-Half/Full duplex does not match physical port config