Set SSID of wireless Bolt configured as a client

Given a wireless Bolt configured as a client, how can we specify the SSID to connect to via an AT command? We know the SSID can be set via the web interface (WLAN Settings tab), but in the context of our project, the SSID must be set by the PLC (AT command over TCP). We have looked at the AT command reference manual, but have not found any AT command that does this.

Please see AT Commands Manual page 37:

Hi, thanks for your answer, but as I mentionned, we need to set the SSID for client mode. Is it the same command regardless of the mode?

Sorry, I misunderstood. In that case, I believe you would have to first scan using AT*WSSCAN:

Then write the entry into the Connection list using AT*WSCLW:

But I will double check with the Anybus Wireless team to check that this is correct.

When running the AT* command, I don’t see the AT*WLSCL= command.
The firmware currently on our Bolt is 2.06.03

It’s WSCLW, not WLSCL.

I made a typo I’m sorry. However, WSCLW is also not in the list of supported AT commands.

Here is the info from the Anybus wireless engineer:

Now we use the AT*WSDP=ssid

AT&F Restore to factory settings
ATS1015=2 WLAN Radio only
ATWSAM=2,1 Auth Mode WPA/WPA2
WKEY=WPAkey,1 Enter the WPA2 Key
AT*WSBM=1 Select Mode 1=Layer 2 MAC clone
ATS3018=20 Enable Auto MAC clone with 20 attempts to get MAC

And if they need to change IP:

After all the used AT commands, they end with AT*AMREBOOT to reboot the device with the new settings.

If they want to do a selection of available networks using AT commands, then they need to select what part is relevant to them, and start with the WSSCAN as you describe, but if they know the ssid already and want to do a complete setup from scratch they can use the example above.

Hi, I just tested your sequence of commands and it works. However, I just want to point out that there must be an asterisk * after the AT in the following commands:


Yes, of course. Thanks for the update.