Systematic error warning after connection with simplycan

I just got a simplycan device and I’m unable to make it work properly.
I try to use it to send and receive can messages to a device I’m developping. The can bus works perfectly as two devices are able to communicate together.
The baudrate is 1MHz.
But when I try to communicate with Simplycan BusMonitor through my simplycan, I have systematically the CAN redlight flashing right after pressing the button CAN Start. I tried with other baudrate as I can select the baudrate on my device, but the problem is still the same.
If I try to send a message the red light stop flashing and stays red, as I have red it means the bus is off.
With no message sent or received the bus is in error, whenever I send a message the bus is off.
I work under Windows 10 and have the busmonitor v 1.3.0.

As there is not a lot of parameters I can change I really don’t know what can cause those errors.

Could you help me with this issue ?

This is most likely a connection issue. Do you have termination resistors installed?

Thank you for your answer.
We have tried to put a 120Ohm resistor at the end of the line (on our device side) but the result was still the same.
Is it necessary to install a resistor on the simplyCan side too ?

Yes, both sides of a CAN bus should be terminated.